import re
regex = re.compile(r"^(?:GB\d{2}[A-Z]{4}\d{14}|DE\d{20})|[A-Z]{2}(?<!DE|GB)(?:[A-Z]|\d){13,}$", flags=re.MULTILINE)
test_str = ("works as expected\n"
"DE12312341212312312312\n"
"GB12ASDF12312312312311\n\n"
"this should match with fallback\n"
"NO1212121212121\n"
"BG18RZBB91550123456789\n\n"
"this should not match with fallback:\n"
"DE1231234121231\n"
"GB1231231231231")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")