package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)(\s+\/.*)$`)
var str = `123 / some text 123
anything else / some text 123`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}