re = /^(.*?)(\s+\/.*)$/m
str = '123 / some text 123
anything else / some text 123'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result