#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)[\s\S]*my_delimiter|name:\s*(.*)$"
Local $sString = "Some data" & @CRLF & _
"name: Person 1" & @CRLF & _
"Some data" & @CRLF & _
"my_delimiter:" & @CRLF & _
" name: Person 2" & @CRLF & _
" Some data" & @CRLF & _
"name: Person 3" & @CRLF & _
"Some data" & @CRLF & _
" name: Person 4" & @CRLF & _
" Some data" & @CRLF & _
"Some data" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")