package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)[\s\S]*my_delimiter|name:\s*(.*)$`)
var str = `Some data
name: Person 1
Some data
my_delimiter:
name: Person 2
Some data
name: Person 3
Some data
name: Person 4
Some data
Some data
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}