#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)COV2-([0-9]+)([\s]+)([A-Z]+)"
Local $sString = "          Name                    CDRH3" & @CRLF & _
                "0    COV2-2997          ARGAIPPNSRAEIDY" & @CRLF & _
                "1    COV2-3012         ARVLYDSSGFYNWFDP" & @CRLF & _
                "2    COV2-2961         AAPYCSSISCNDGFDI" & @CRLF & _
                "3    COV2-3025         AAPYCSSISCNDGFDI" & @CRLF & _
                "4    COV2-2046         AKAHSTGHQYYYGMDV" & @CRLF & _
                "5    COV2-2196         AAPYCSSISCNDGFDI" & @CRLF & _
                "6    COV2-2901         ARSYDILTGYRDAFDI" & @CRLF & _
                "7    COV2-2070         ARVGYSQGYYYYYMDV" & @CRLF & _
                "8    COV2-2132               ARDFLRWHDL" & @CRLF & _
                "9    COV2-2911          ARMSRGYNYAYTFDI" & @CRLF & _
                "10   COV2-2098               VKGLFDWFPL" & @CRLF & _
                "11   COV2-2108          AKGVDYGGKLAYFDS" & @CRLF & _
                "12   COV2-2114        ARGRGYSNYGASYYMDV" & @CRLF & _
                "13   COV2-2304     ARDPVWVDGELLSGGIPFDY" & @CRLF & _
                "14   COV2-2078       ARVGVSGFKSGSNWYFDL" & @CRLF & _
                "15   COV2-2299         ARDIDSGYDPTPVFDY" & @CRLF & _
                "16   COV2-2351             ARRFYGPSSFDY" & @CRLF & _
                "17   COV2-2318                ARGVVTYDY" & @CRLF & _
                "18   COV2-2703            ARARGGYNWNFDY" & @CRLF & _
                "19   COV2-2277         ARDVPTTVTAFTVFTY" & @CRLF & _
                "20   COV2-2068         ARSYDILTGYRDAFDI" & @CRLF & _
                "21   COV2-2504  ARVVVLGYGRPNNYYDGRNVWDY" & @CRLF & _
                "22   COV2-2510          ARWGPDYGDYASNDY" & @CRLF & _
                "23   COV2-2308               VKGLFDWFPL" & @CRLF & _
                "24   COV2-2391         ARMRSGWPTHGRPDDF" & @CRLF & _
                "25   COV2-2767         ARSYDILTGYRDAFDI" & @CRLF & _
                "26   COV2-2113               ARDFLRWHDL" & @CRLF & _
                "27   COV2-2290         ARMRSGWPTHGRPDDF" & @CRLF & _
                "28   COV2-2130   TTAGSYYYDTVGPGLPEGKFDY" & @CRLF & _
                "29   COV2-2050  ARVVVLGYGRPNNYYDGRNVWDY" & @CRLF & _
                "..         ...                      ..." & @CRLF & _
                "355  COV2-2587             AHRLWFRDAFDI" & @CRLF & _
                "356  COV2-2551         ASGPPYMATFSYYFDY" & @CRLF & _
                "357  COV2-2481        ARGWFGELLKGTYWFDP" & @CRLF & _
                "358  COV2-2029            ARPTAGAGGAFDI" & @CRLF & _
                "359  COV2-2590  ARGRVGYVGSGSRGYYYYYDMDV" & @CRLF & _
                "360  COV2-2408        ARVGGISPYYYYYYMDV" & @CRLF & _
                "361  COV2-2565                ARGAASFDY" & @CRLF & _
                "362  COV2-2641           AKSYNGNYYDAFDI" & @CRLF & _
                "363  COV2-2449        ARASYNSNWSIGEYFRD" & @CRLF & _
                "364  COV2-2619    ARVEGDWLLGGPYYHYYGMDV" & @CRLF & _
                "365  COV2-2367          ARTSHYDSSGSYFEY" & @CRLF & _
                "366  COV2-2343               ARVQRRRLDY" & @CRLF & _
                "367  COV2-2270          AITYYYDSSGYWWDD" & @CRLF & _
                "368  COV2-2187               ARGGATNFDY" & @CRLF & _
                "369  COV2-2478           AKGIYYDIFMPLLD" & @CRLF & _
                "370  COV2-2820    ARDQSQGAYILTGYRGYGMDV" & @CRLF & _
                "371  COV2-2620           ARADTMVRGTYFEY" & @CRLF & _
                "372  COV2-2171             ARLSGSSWDFDY" & @CRLF & _
                "373  COV2-2583    ARGGIYYLVRGFIIGYYGMDV" & @CRLF & _
                "374  COV2-2227    ARDQSQGAYILTGYRGYGMDV" & @CRLF & _
                "375  COV2-2160           ARSTSGSYYYGMDV" & @CRLF & _
                "376  COV2-2178             ARVGSSSWYFDY" & @CRLF & _
                "377  COV2-2159           ARSTSGSYYYGMDV" & @CRLF & _
                "378  COV2-2166          ARIGHFDSSGYYLDY" & @CRLF & _
                "379  COV2-2224              AKDGSIAAADY" & @CRLF & _
                "380  COV2-2214          ARIGHFDSSGYYLDY" & @CRLF & _
                "381  COV2-2218           ARPYTGSYKSYMDV" & @CRLF & _
                "382  COV2-2216          ARTSHYDSSGSYFEY" & @CRLF & _
                "383  COV2-2175             ARLSGSSWDFDY" & @CRLF & _
                "384  COV2-2183           ARADTMVRGTYFEY" & @CRLF & _
                "" & @CRLF & _
                "[385 rows x 2 columns]" & @CRLF & _
                "          Name                    CDRH3" & @CRLF & _
                "0    COV2-2997          ARGAIPPNSRAEIDY" & @CRLF & _
                "1    COV2-3012         ARVLYDSSGFYNWFDP" & @CRLF & _
                "2    COV2-2961         AAPYCSSISCNDGFDI" & @CRLF & _
                "3    COV2-3025         AAPYCSSISCNDGFDI" & @CRLF & _
                "4    COV2-2046         AKAHSTGHQYYYGMDV" & @CRLF & _
                "5    COV2-2196         AAPYCSSISCNDGFDI" & @CRLF & _
                "6    COV2-2901         ARSYDILTGYRDAFDI" & @CRLF & _
                "7    COV2-2070         ARVGYSQGYYYYYMDV" & @CRLF & _
                "8    COV2-2132               ARDFLRWHDL" & @CRLF & _
                "9    COV2-2911          ARMSRGYNYAYTFDI" & @CRLF & _
                "10   COV2-2098               VKGLFDWFPL" & @CRLF & _
                "11   COV2-2108          AKGVDYGGKLAYFDS" & @CRLF & _
                "12   COV2-2114        ARGRGYSNYGASYYMDV" & @CRLF & _
                "13   COV2-2304     ARDPVWVDGELLSGGIPFDY" & @CRLF & _
                "14   COV2-2078       ARVGVSGFKSGSNWYFDL" & @CRLF & _
                "15   COV2-2299         ARDIDSGYDPTPVFDY" & @CRLF & _
                "16   COV2-2351             ARRFYGPSSFDY" & @CRLF & _
                "17   COV2-2318                ARGVVTYDY" & @CRLF & _
                "18   COV2-2703            ARARGGYNWNFDY" & @CRLF & _
                "19   COV2-2277         ARDVPTTVTAFTVFTY" & @CRLF & _
                "20   COV2-2068         ARSYDILTGYRDAFDI" & @CRLF & _
                "21   COV2-2504  ARVVVLGYGRPNNYYDGRNVWDY" & @CRLF & _
                "22   COV2-2510          ARWGPDYGDYASNDY" & @CRLF & _
                "23   COV2-2308               VKGLFDWFPL" & @CRLF & _
                "24   COV2-2391         ARMRSGWPTHGRPDDF" & @CRLF & _
                "25   COV2-2767         ARSYDILTGYRDAFDI" & @CRLF & _
                "26   COV2-2113               ARDFLRWHDL" & @CRLF & _
                "27   COV2-2290         ARMRSGWPTHGRPDDF" & @CRLF & _
                "28   COV2-2130   TTAGSYYYDTVGPGLPEGKFDY" & @CRLF & _
                "29   COV2-2050  ARVVVLGYGRPNNYYDGRNVWDY" & @CRLF & _
                "..         ...                      ..." & @CRLF & _
                "355  COV2-2587             AHRLWFRDAFDI" & @CRLF & _
                "356  COV2-2551         ASGPPYMATFSYYFDY" & @CRLF & _
                "357  COV2-2481        ARGWFGELLKGTYWFDP" & @CRLF & _
                "358  COV2-2029            ARPTAGAGGAFDI" & @CRLF & _
                "359  COV2-2590  ARGRVGYVGSGSRGYYYYYDMDV" & @CRLF & _
                "360  COV2-2408        ARVGGISPYYYYYYMDV" & @CRLF & _
                "361  COV2-2565                ARGAASFDY" & @CRLF & _
                "362  COV2-2641           AKSYNGNYYDAFDI" & @CRLF & _
                "363  COV2-2449        ARASYNSNWSIGEYFRD" & @CRLF & _
                "364  COV2-2619    ARVEGDWLLGGPYYHYYGMDV" & @CRLF & _
                "365  COV2-2367          ARTSHYDSSGSYFEY" & @CRLF & _
                "366  COV2-2343               ARVQRRRLDY" & @CRLF & _
                "367  COV2-2270          AITYYYDSSGYWWDD" & @CRLF & _
                "368  COV2-2187               ARGGATNFDY" & @CRLF & _
                "369  COV2-2478           AKGIYYDIFMPLLD" & @CRLF & _
                "370  COV2-2820    ARDQSQGAYILTGYRGYGMDV" & @CRLF & _
                "371  COV2-2620           ARADTMVRGTYFEY" & @CRLF & _
                "372  COV2-2171             ARLSGSSWDFDY" & @CRLF & _
                "373  COV2-2583    ARGGIYYLVRGFIIGYYGMDV" & @CRLF & _
                "374  COV2-2227    ARDQSQGAYILTGYRGYGMDV" & @CRLF & _
                "375  COV2-2160           ARSTSGSYYYGMDV" & @CRLF & _
                "376  COV2-2178             ARVGSSSWYFDY" & @CRLF & _
                "377  COV2-2159           ARSTSGSYYYGMDV" & @CRLF & _
                "378  COV2-2166          ARIGHFDSSGYYLDY" & @CRLF & _
                "379  COV2-2224              AKDGSIAAADY" & @CRLF & _
                "380  COV2-2214          ARIGHFDSSGYYLDY" & @CRLF & _
                "381  COV2-2218           ARPYTGSYKSYMDV" & @CRLF & _
                "382  COV2-2216          ARTSHYDSSGSYFEY" & @CRLF & _
                "383  COV2-2175             ARLSGSSWDFDY" & @CRLF & _
                "384  COV2-2183           ARADTMVRGTYFEY" & @CRLF & _
                "" & @CRLF & _
                "[385 rows x 2 columns]" & @CRLF & _
                "          Name                    CDRH3" & @CRLF & _
                "0    COV2-2997          ARGAIPPNSRAEIDY" & @CRLF & _
                "1    COV2-3012         ARVLYDSSGFYNWFDP" & @CRLF & _
                "2    COV2-2961         AAPYCSSISCNDGFDI" & @CRLF & _
                "3    COV2-3025         AAPYCSSISCNDGFDI" & @CRLF & _
                "4    COV2-2046         AKAHSTGHQYYYGMDV" & @CRLF & _
                "5    COV2-2196         AAPYCSSISCNDGFDI" & @CRLF & _
                "6    COV2-2901         ARSYDILTGYRDAFDI" & @CRLF & _
                "7    COV2-2070         ARVGYSQGYYYYYMDV" & @CRLF & _
                "8    COV2-2132               ARDFLRWHDL" & @CRLF & _
                "9    COV2-2911          ARMSRGYNYAYTFDI" & @CRLF & _
                "10   COV2-2098               VKGLFDWFPL" & @CRLF & _
                "11   COV2-2108          AKGVDYGGKLAYFDS" & @CRLF & _
                "12   COV2-2114        ARGRGYSNYGASYYMDV" & @CRLF & _
                "13   COV2-2304     ARDPVWVDGELLSGGIPFDY" & @CRLF & _
                "14   COV2-2078       ARVGVSGFKSGSNWYFDL" & @CRLF & _
                "15   COV2-2299         ARDIDSGYDPTPVFDY" & @CRLF & _
                "16   COV2-2351             ARRFYGPSSFDY" & @CRLF & _
                "17   COV2-2318                ARGVVTYDY" & @CRLF & _
                "18   COV2-2703            ARARGGYNWNFDY" & @CRLF & _
                "19   COV2-2277         ARDVPTTVTAFTVFTY" & @CRLF & _
                "20   COV2-2068         ARSYDILTGYRDAFDI" & @CRLF & _
                "21   COV2-2504  ARVVVLGYGRPNNYYDGRNVWDY" & @CRLF & _
                "22   COV2-2510          ARWGPDYGDYASNDY" & @CRLF & _
                "23   COV2-2308               VKGLFDWFPL" & @CRLF & _
                "24   COV2-2391         ARMRSGWPTHGRPDDF" & @CRLF & _
                "25   COV2-2767         ARSYDILTGYRDAFDI" & @CRLF & _
                "26   COV2-2113               ARDFLRWHDL" & @CRLF & _
                "27   COV2-2290         ARMRSGWPTHGRPDDF" & @CRLF & _
                "28   COV2-2130   TTAGSYYYDTVGPGLPEGKFDY" & @CRLF & _
                "29   COV2-2050  ARVVVLGYGRPNNYYDGRNVWDY" & @CRLF & _
                "..         ...                      ..." & @CRLF & _
                "355  COV2-2587             AHRLWFRDAFDI" & @CRLF & _
                "356  COV2-2551         ASGPPYMATFSYYFDY" & @CRLF & _
                "357  COV2-2481        ARGWFGELLKGTYWFDP" & @CRLF & _
                "358  COV2-2029            ARPTAGAGGAFDI" & @CRLF & _
                "359  COV2-2590  ARGRVGYVGSGSRGYYYYYDMDV" & @CRLF & _
                "360  COV2-2408        ARVGGISPYYYYYYMDV" & @CRLF & _
                "361  COV2-2565                ARGAASFDY" & @CRLF & _
                "362  COV2-2641           AKSYNGNYYDAFDI" & @CRLF & _
                "363  COV2-2449        ARASYNSNWSIGEYFRD" & @CRLF & _
                "364  COV2-2619    ARVEGDWLLGGPYYHYYGMDV" & @CRLF & _
                "365  COV2-2367          ARTSHYDSSGSYFEY" & @CRLF & _
                "366  COV2-2343               ARVQRRRLDY" & @CRLF & _
                "367  COV2-2270          AITYYYDSSGYWWDD" & @CRLF & _
                "368  COV2-2187               ARGGATNFDY" & @CRLF & _
                "369  COV2-2478           AKGIYYDIFMPLLD" & @CRLF & _
                "370  COV2-2820    ARDQSQGAYILTGYRGYGMDV" & @CRLF & _
                "371  COV2-2620           ARADTMVRGTYFEY" & @CRLF & _
                "372  COV2-2171             ARLSGSSWDFDY" & @CRLF & _
                "373  COV2-2583    ARGGIYYLVRGFIIGYYGMDV" & @CRLF & _
                "374  COV2-2227    ARDQSQGAYILTGYRGYGMDV" & @CRLF & _
                "375  COV2-2160           ARSTSGSYYYGMDV" & @CRLF & _
                "376  COV2-2178             ARVGSSSWYFDY" & @CRLF & _
                "377  COV2-2159           ARSTSGSYYYGMDV" & @CRLF & _
                "378  COV2-2166          ARIGHFDSSGYYLDY" & @CRLF & _
                "379  COV2-2224              AKDGSIAAADY" & @CRLF & _
                "380  COV2-2214          ARIGHFDSSGYYLDY" & @CRLF & _
                "381  COV2-2218           ARPYTGSYKSYMDV" & @CRLF & _
                "382  COV2-2216          ARTSHYDSSGSYFEY" & @CRLF & _
                "383  COV2-2175             ARLSGSSWDFDY" & @CRLF & _
                "384  COV2-2183           ARADTMVRGTYFEY" & @CRLF & _
                "" & @CRLF & _
                "[385 rows x 2 columns]" & @CRLF & _
                ""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")