const regex = new RegExp('COV2-([0-9]+)([\\s]+)([A-Z]+)', 'gm')
const str = ` Name CDRH3
0 COV2-2997 ARGAIPPNSRAEIDY
1 COV2-3012 ARVLYDSSGFYNWFDP
2 COV2-2961 AAPYCSSISCNDGFDI
3 COV2-3025 AAPYCSSISCNDGFDI
4 COV2-2046 AKAHSTGHQYYYGMDV
5 COV2-2196 AAPYCSSISCNDGFDI
6 COV2-2901 ARSYDILTGYRDAFDI
7 COV2-2070 ARVGYSQGYYYYYMDV
8 COV2-2132 ARDFLRWHDL
9 COV2-2911 ARMSRGYNYAYTFDI
10 COV2-2098 VKGLFDWFPL
11 COV2-2108 AKGVDYGGKLAYFDS
12 COV2-2114 ARGRGYSNYGASYYMDV
13 COV2-2304 ARDPVWVDGELLSGGIPFDY
14 COV2-2078 ARVGVSGFKSGSNWYFDL
15 COV2-2299 ARDIDSGYDPTPVFDY
16 COV2-2351 ARRFYGPSSFDY
17 COV2-2318 ARGVVTYDY
18 COV2-2703 ARARGGYNWNFDY
19 COV2-2277 ARDVPTTVTAFTVFTY
20 COV2-2068 ARSYDILTGYRDAFDI
21 COV2-2504 ARVVVLGYGRPNNYYDGRNVWDY
22 COV2-2510 ARWGPDYGDYASNDY
23 COV2-2308 VKGLFDWFPL
24 COV2-2391 ARMRSGWPTHGRPDDF
25 COV2-2767 ARSYDILTGYRDAFDI
26 COV2-2113 ARDFLRWHDL
27 COV2-2290 ARMRSGWPTHGRPDDF
28 COV2-2130 TTAGSYYYDTVGPGLPEGKFDY
29 COV2-2050 ARVVVLGYGRPNNYYDGRNVWDY
.. ... ...
355 COV2-2587 AHRLWFRDAFDI
356 COV2-2551 ASGPPYMATFSYYFDY
357 COV2-2481 ARGWFGELLKGTYWFDP
358 COV2-2029 ARPTAGAGGAFDI
359 COV2-2590 ARGRVGYVGSGSRGYYYYYDMDV
360 COV2-2408 ARVGGISPYYYYYYMDV
361 COV2-2565 ARGAASFDY
362 COV2-2641 AKSYNGNYYDAFDI
363 COV2-2449 ARASYNSNWSIGEYFRD
364 COV2-2619 ARVEGDWLLGGPYYHYYGMDV
365 COV2-2367 ARTSHYDSSGSYFEY
366 COV2-2343 ARVQRRRLDY
367 COV2-2270 AITYYYDSSGYWWDD
368 COV2-2187 ARGGATNFDY
369 COV2-2478 AKGIYYDIFMPLLD
370 COV2-2820 ARDQSQGAYILTGYRGYGMDV
371 COV2-2620 ARADTMVRGTYFEY
372 COV2-2171 ARLSGSSWDFDY
373 COV2-2583 ARGGIYYLVRGFIIGYYGMDV
374 COV2-2227 ARDQSQGAYILTGYRGYGMDV
375 COV2-2160 ARSTSGSYYYGMDV
376 COV2-2178 ARVGSSSWYFDY
377 COV2-2159 ARSTSGSYYYGMDV
378 COV2-2166 ARIGHFDSSGYYLDY
379 COV2-2224 AKDGSIAAADY
380 COV2-2214 ARIGHFDSSGYYLDY
381 COV2-2218 ARPYTGSYKSYMDV
382 COV2-2216 ARTSHYDSSGSYFEY
383 COV2-2175 ARLSGSSWDFDY
384 COV2-2183 ARADTMVRGTYFEY
[385 rows x 2 columns]
Name CDRH3
0 COV2-2997 ARGAIPPNSRAEIDY
1 COV2-3012 ARVLYDSSGFYNWFDP
2 COV2-2961 AAPYCSSISCNDGFDI
3 COV2-3025 AAPYCSSISCNDGFDI
4 COV2-2046 AKAHSTGHQYYYGMDV
5 COV2-2196 AAPYCSSISCNDGFDI
6 COV2-2901 ARSYDILTGYRDAFDI
7 COV2-2070 ARVGYSQGYYYYYMDV
8 COV2-2132 ARDFLRWHDL
9 COV2-2911 ARMSRGYNYAYTFDI
10 COV2-2098 VKGLFDWFPL
11 COV2-2108 AKGVDYGGKLAYFDS
12 COV2-2114 ARGRGYSNYGASYYMDV
13 COV2-2304 ARDPVWVDGELLSGGIPFDY
14 COV2-2078 ARVGVSGFKSGSNWYFDL
15 COV2-2299 ARDIDSGYDPTPVFDY
16 COV2-2351 ARRFYGPSSFDY
17 COV2-2318 ARGVVTYDY
18 COV2-2703 ARARGGYNWNFDY
19 COV2-2277 ARDVPTTVTAFTVFTY
20 COV2-2068 ARSYDILTGYRDAFDI
21 COV2-2504 ARVVVLGYGRPNNYYDGRNVWDY
22 COV2-2510 ARWGPDYGDYASNDY
23 COV2-2308 VKGLFDWFPL
24 COV2-2391 ARMRSGWPTHGRPDDF
25 COV2-2767 ARSYDILTGYRDAFDI
26 COV2-2113 ARDFLRWHDL
27 COV2-2290 ARMRSGWPTHGRPDDF
28 COV2-2130 TTAGSYYYDTVGPGLPEGKFDY
29 COV2-2050 ARVVVLGYGRPNNYYDGRNVWDY
.. ... ...
355 COV2-2587 AHRLWFRDAFDI
356 COV2-2551 ASGPPYMATFSYYFDY
357 COV2-2481 ARGWFGELLKGTYWFDP
358 COV2-2029 ARPTAGAGGAFDI
359 COV2-2590 ARGRVGYVGSGSRGYYYYYDMDV
360 COV2-2408 ARVGGISPYYYYYYMDV
361 COV2-2565 ARGAASFDY
362 COV2-2641 AKSYNGNYYDAFDI
363 COV2-2449 ARASYNSNWSIGEYFRD
364 COV2-2619 ARVEGDWLLGGPYYHYYGMDV
365 COV2-2367 ARTSHYDSSGSYFEY
366 COV2-2343 ARVQRRRLDY
367 COV2-2270 AITYYYDSSGYWWDD
368 COV2-2187 ARGGATNFDY
369 COV2-2478 AKGIYYDIFMPLLD
370 COV2-2820 ARDQSQGAYILTGYRGYGMDV
371 COV2-2620 ARADTMVRGTYFEY
372 COV2-2171 ARLSGSSWDFDY
373 COV2-2583 ARGGIYYLVRGFIIGYYGMDV
374 COV2-2227 ARDQSQGAYILTGYRGYGMDV
375 COV2-2160 ARSTSGSYYYGMDV
376 COV2-2178 ARVGSSSWYFDY
377 COV2-2159 ARSTSGSYYYGMDV
378 COV2-2166 ARIGHFDSSGYYLDY
379 COV2-2224 AKDGSIAAADY
380 COV2-2214 ARIGHFDSSGYYLDY
381 COV2-2218 ARPYTGSYKSYMDV
382 COV2-2216 ARTSHYDSSGSYFEY
383 COV2-2175 ARLSGSSWDFDY
384 COV2-2183 ARADTMVRGTYFEY
[385 rows x 2 columns]
Name CDRH3
0 COV2-2997 ARGAIPPNSRAEIDY
1 COV2-3012 ARVLYDSSGFYNWFDP
2 COV2-2961 AAPYCSSISCNDGFDI
3 COV2-3025 AAPYCSSISCNDGFDI
4 COV2-2046 AKAHSTGHQYYYGMDV
5 COV2-2196 AAPYCSSISCNDGFDI
6 COV2-2901 ARSYDILTGYRDAFDI
7 COV2-2070 ARVGYSQGYYYYYMDV
8 COV2-2132 ARDFLRWHDL
9 COV2-2911 ARMSRGYNYAYTFDI
10 COV2-2098 VKGLFDWFPL
11 COV2-2108 AKGVDYGGKLAYFDS
12 COV2-2114 ARGRGYSNYGASYYMDV
13 COV2-2304 ARDPVWVDGELLSGGIPFDY
14 COV2-2078 ARVGVSGFKSGSNWYFDL
15 COV2-2299 ARDIDSGYDPTPVFDY
16 COV2-2351 ARRFYGPSSFDY
17 COV2-2318 ARGVVTYDY
18 COV2-2703 ARARGGYNWNFDY
19 COV2-2277 ARDVPTTVTAFTVFTY
20 COV2-2068 ARSYDILTGYRDAFDI
21 COV2-2504 ARVVVLGYGRPNNYYDGRNVWDY
22 COV2-2510 ARWGPDYGDYASNDY
23 COV2-2308 VKGLFDWFPL
24 COV2-2391 ARMRSGWPTHGRPDDF
25 COV2-2767 ARSYDILTGYRDAFDI
26 COV2-2113 ARDFLRWHDL
27 COV2-2290 ARMRSGWPTHGRPDDF
28 COV2-2130 TTAGSYYYDTVGPGLPEGKFDY
29 COV2-2050 ARVVVLGYGRPNNYYDGRNVWDY
.. ... ...
355 COV2-2587 AHRLWFRDAFDI
356 COV2-2551 ASGPPYMATFSYYFDY
357 COV2-2481 ARGWFGELLKGTYWFDP
358 COV2-2029 ARPTAGAGGAFDI
359 COV2-2590 ARGRVGYVGSGSRGYYYYYDMDV
360 COV2-2408 ARVGGISPYYYYYYMDV
361 COV2-2565 ARGAASFDY
362 COV2-2641 AKSYNGNYYDAFDI
363 COV2-2449 ARASYNSNWSIGEYFRD
364 COV2-2619 ARVEGDWLLGGPYYHYYGMDV
365 COV2-2367 ARTSHYDSSGSYFEY
366 COV2-2343 ARVQRRRLDY
367 COV2-2270 AITYYYDSSGYWWDD
368 COV2-2187 ARGGATNFDY
369 COV2-2478 AKGIYYDIFMPLLD
370 COV2-2820 ARDQSQGAYILTGYRGYGMDV
371 COV2-2620 ARADTMVRGTYFEY
372 COV2-2171 ARLSGSSWDFDY
373 COV2-2583 ARGGIYYLVRGFIIGYYGMDV
374 COV2-2227 ARDQSQGAYILTGYRGYGMDV
375 COV2-2160 ARSTSGSYYYGMDV
376 COV2-2178 ARVGSSSWYFDY
377 COV2-2159 ARSTSGSYYYGMDV
378 COV2-2166 ARIGHFDSSGYYLDY
379 COV2-2224 AKDGSIAAADY
380 COV2-2214 ARIGHFDSSGYYLDY
381 COV2-2218 ARPYTGSYKSYMDV
382 COV2-2216 ARTSHYDSSGSYFEY
383 COV2-2175 ARLSGSSWDFDY
384 COV2-2183 ARADTMVRGTYFEY
[385 rows x 2 columns]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}