$re = '/.*public.*|$/mi';
$str = 'Technical College, CN = Jim\'s Root CA
**Subject Public Key Info:
Public Key Algorithm: rsaEncryption
RSA Public-Key: (4096 bit)**
Modulus:
00: bc: e9:14: f5:63:4b:30: d9:50:6a: 38:f6:5f:ae:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);