// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi).*public.*|$").unwrap();
let string = "Technical College, CN = Jim's Root CA
**Subject Public Key Info:
Public Key Algorithm: rsaEncryption
RSA Public-Key: (4096 bit)**
Modulus:
00: bc: e9:14: f5:63:4b:30: d9:50:6a: 38:f6:5f:ae:";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}