use strict;
my $str = '<p>Lorem ipsum dolor sit amet.</p><img src="https://lh5.googleusercontent.com/-1G1Z51IFZe4/TYbMLgP8ObI/AAAAAAAAAas/WteAs_b7xzc/s320/herminafinal.jpg" /><p>Lorem ipsum dolor sit amet.</p>';
my $regex = qr/<img\b[^<>]*?src=(['"].*?\/)([^.\/<>]*\.[^.\/<>]*)['"][^><]*?\/>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}