#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<unit_type>SL|SV)(?P<unit_size>10|15|20|25|30)(?P<mounting_type>P|G)(?P<decompression_feature>A|B)(?P<cracking_pressure>1|2|3|4)(?P<sep_1>-)(?P<unit_series>4X)(?P<sep_2>/|=)(?P<pilot_valve>6U|)(?P<type_of_limit_switch>QM|)(?P<power_supply_of_limit_switch>G24|)(?P<sep_3>/|)(?P<seal_material>M|V|)(?P<sep_4>/|)(?P<surface_coating>J3|)(?P<pipe_port>/12|)(?P<additional_details>(.|[0-9])*)$"
Local $sString = "SV20PB1-4X/V" & @CRLF & _
"SV10GA3-4X/V" & @CRLF & _
"SL20GB1-4X/M/12" & @CRLF & _
"SV30PB2-4X/V" & @CRLF & _
"SV20GA2-4X/V" & @CRLF & _
"SL30PB2-4X/V" & @CRLF & _
"SV20GB3-4X/M/12" & @CRLF & _
"SL20PB4-4X/V" & @CRLF & _
"SL10GA1-4X/V/12" & @CRLF & _
"SV20GB4-4X/V" & @CRLF & _
"SV20GA1-4X=M" & @CRLF & _
"SV20GB1-4X/M/12" & @CRLF & _
"SL20GA3-4X/V" & @CRLF & _
"SV20GA3-4X/M/12" & @CRLF & _
"SL30PB4-4X/V" & @CRLF & _
"SL20PA1-4X/MSO286" & @CRLF & _
"SV10GA2-4X/M/12" & @CRLF & _
"SL20GA1-4X/V/12" & @CRLF & _
"SL10PB1-4X/MSO286" & @CRLF & _
"SV30GB2-4X/V" & @CRLF & _
"SV30GA1-4X/V/12" & @CRLF & _
"SL30GA1-4X/V/12=" & @CRLF & _
"SV30PB4-4X/V" & @CRLF & _
"SL25GB3-4X/" & @CRLF & _
"SV10GA3-4X/M" & @CRLF & _
"SV10GB3-4X/M" & @CRLF & _
"SV10PA2-4X/V" & @CRLF & _
"SL10PA4-4X/V" & @CRLF & _
"SV10PB2-4X/M" & @CRLF & _
"SL10PB1-4X/V" & @CRLF & _
"SL10PA4-4X/M" & @CRLF & _
"SV10PB1-4X/V" & @CRLF & _
"SV10GB1-4X/M/12" & @CRLF & _
"SL10PB3-4X/M" & @CRLF & _
"SV10GB1-4X/V" & @CRLF & _
"SL10PA2-4X/M" & @CRLF & _
"SL10PA3-4X/M" & @CRLF & _
"SL10PB1-4X/M" & @CRLF & _
"SL10GA4-4X/M" & @CRLF & _
"SL10GB3-4X/M" & @CRLF & _
"SL10GA1-4X/M/12" & @CRLF & _
"SL10GA1-4X/V" & @CRLF & _
"SL10GA2-4X/M" & @CRLF & _
"SV10PA2-4X/M" & @CRLF & _
"SL10GB1-4X/M" & @CRLF & _
"SL10PB4-4X/M" & @CRLF & _
"SV10GB1-4X/M" & @CRLF & _
"SL10GA3-4X/M" & @CRLF & _
"SV10GA2-4X/M" & @CRLF & _
"SV10GB4-4X/M" & @CRLF & _
"SL10PB2-4X/M" & @CRLF & _
"SL10PA1-4X/V" & @CRLF & _
"SV10PA3-4X/M" & @CRLF & _
"SV10GA1-4X/V/12" & @CRLF & _
"SV10PA1-4X/V" & @CRLF & _
"SV10PB3-4X/M" & @CRLF & _
"SV10GB2-4X/M" & @CRLF & _
"SV10GA1-4X/V" & @CRLF & _
"SV10PA3-4X/V" & @CRLF & _
"SV10PB1-4X/M" & @CRLF & _
"SL10GB2-4X/V" & @CRLF & _
"SL10GB2-4X/M" & @CRLF & _
"SV10GA2-4X/V/12" & @CRLF & _
"SV10GA1-4X/M/12" & @CRLF & _
"SV10GA2-4X/V" & @CRLF & _
"SV10GA1-4X/M" & @CRLF & _
"SV10PA1-4X/M" & @CRLF & _
"SL10GA1-4X/M" & @CRLF & _
"SL10PA1-4X/M" & @CRLF & _
"SL30GA3-4X/M" & @CRLF & _
"SV30GA3-4X/M" & @CRLF & _
"SL20GB2-4X/M" & @CRLF & _
"SV20PA1-4X/V" & @CRLF & _
"SL30PA1-4X/V" & @CRLF & _
"SL20PB2-4X/M" & @CRLF & _
"SV20GA2-4X/M" & @CRLF & _
"SV20GA1-4X/V" & @CRLF & _
"SV10PB4-4X/V" & @CRLF & _
"SL20GB1-4X/M" & @CRLF & _
"SV25GB3-4X/" & @CRLF & _
"SL20PB3-4X/M" & @CRLF & _
"SL25GB2-4X/" & @CRLF & _
"SL30GB1-4X/M" & @CRLF & _
"SL30GA2-4X/M" & @CRLF & _
"SL20PA4-4X/M" & @CRLF & _
"SV20GB4-4X/M" & @CRLF & _
"SL20PA2-4X/V" & @CRLF & _
"SV30PA1-4X/V" & @CRLF & _
"SV25GA2-4X/" & @CRLF & _
"SV30GA2-4X/M" & @CRLF & _
"SL20PA3-4X/V" & @CRLF & _
"SV20PB3-4X/M" & @CRLF & _
"SL20PA1-4X/V" & @CRLF & _
"SL30PA4-4X/M" & @CRLF & _
"SV20PB1-4X/M" & @CRLF & _
"SV20PB2-4X/M" & @CRLF & _
"SL30PA4-4X/V" & @CRLF & _
"SV30PA2-4X/V" & @CRLF & _
"SV20PA3-4X/V" & @CRLF & _
"SL30GB2-4X/M" & @CRLF & _
"SV30PB1-4X/M" & @CRLF & _
"SL30GA1-4X/M/12" & @CRLF & _
"SL10GA2-4X/V" & @CRLF & _
"SV20GB3-4X/M" & @CRLF & _
"SL25GB1-4X/V" & @CRLF & _
"SL30GB2-4X/V/12" & @CRLF & _
"SL25GA3-4X/" & @CRLF & _
"SL30PB2-4X/M" & @CRLF & _
"SV30GB2-4X/M" & @CRLF & _
"SL20GA1-4X/V" & @CRLF & _
"SL20PB2-4X/V" & @CRLF & _
"SL10PA3-4X/V" & @CRLF & _
"SV30PA4-4X/M" & @CRLF & _
"SV10PB4-4X/M" & @CRLF & _
"SL30PB3-4X/M" & @CRLF & _
"SL25GA1-4X/V" & @CRLF & _
"SL20GB3-4X/M" & @CRLF & _
"SV25GA2-4X/V" & @CRLF & _
"SV20PA1-4X/MSO67" & @CRLF & _
"SL10GB1-4X/M/12" & @CRLF & _
"SL30PA1-4X/MSO67" & @CRLF & _
"SL20GA4-4X/M" & @CRLF & _
"SV25GB1-4X/V" & @CRLF & _
"SV20PB4-4X/M" & @CRLF & _
"SV25GA1-4X/V" & @CRLF & _
"SL20GA2-4X/V" & @CRLF & _
"SL30PB1-4X/V" & @CRLF & _
"SV20GA1-4X/M/12" & @CRLF & _
"SL25GA4-4X/" & @CRLF & _
"SL20GA1-4X/M/12" & @CRLF & _
"SV10GA2-4X/MSO43" & @CRLF & _
"SV10GB2-4X/V" & @CRLF & _
"SL20PB1-4X/V" & @CRLF & _
"SL20GB1-4X/V" & @CRLF & _
"SV10GB4-4X/V" & @CRLF & _
"SV10GA4-4X/V" & @CRLF & _
"SL30GA4-4X/M" & @CRLF & _
"SV20GA4-4X/M" & @CRLF & _
"SV20GA4-4X/V" & @CRLF & _
"SV10GA4-4X/MSO287" & @CRLF & _
"SV30PB4-4X/M" & @CRLF & _
"SL30PB4-4X/M" & @CRLF & _
"SL20PB4-4X/M" & @CRLF & _
"SV10GA3-4X/M/12" & @CRLF & _
"SL30PA2-4X/V" & @CRLF & _
"SV25GA4-4X/" & @CRLF & _
"SL10PB2-4X/V" & @CRLF & _
"SL20PA4-4X/V" & @CRLF & _
"SV30GB4-4X/M" & @CRLF & _
"SV30PB3-4X/M" & @CRLF & _
"SV25GB1-4X/" & @CRLF & _
"SV30GA1-4X/M/12" & @CRLF & _
"SV20PB2-4X/V" & @CRLF & _
"SL10PA1-4X/MSO286" & @CRLF & _
"SV20GA2-4X/M/12" & @CRLF & _
"SV20GA1-4X/V/12" & @CRLF & _
"SL30PA3-4X/V" & @CRLF & _
"SV30GA2-4X/V" & @CRLF & _
"SL10GA2-4X/M/12" & @CRLF & _
"SL10GB3-4X/V" & @CRLF & _
"SV25GB2-4X/" & @CRLF & _
"SL20GA1-4X/MSO180" & @CRLF & _
"SL30GB3-4X/M" & @CRLF & _
"SV25GA3-4X/" & @CRLF & _
"SL20GB4-4X/M" & @CRLF & _
"SV30PA4-4X/V" & @CRLF & _
"SL10PB4-4X/V" & @CRLF & _
"SV30GA1-4X/V" & @CRLF & _
"SL30GA2-4X/V" & @CRLF & _
"SV20GB1-4X/V" & @CRLF & _
"SV30GA2-4X/M/12" & @CRLF & _
"SL20PA2-4X/MSO67" & @CRLF & _
"SV20PA4-4X/M" & @CRLF & _
"SL20PB3-4X/V" & @CRLF & _
"SL10GB4-4X/M" & @CRLF & _
"SL30GB4-4X/M" & @CRLF & _
"SL20GB2-4X/V" & @CRLF & _
"SL30GB2-4X/V" & @CRLF & _
"SL25GB2-4X/V" & @CRLF & _
"SL25GA2-4X/V" & @CRLF & _
"SL10GB4-4X/V/12" & @CRLF & _
"SL20GB3-4X/V" & @CRLF & _
"SV30GB1-4X/M/12" & @CRLF & _
"SL20GB1-4X/MSO180" & @CRLF & _
"SV10PA1-4X/MT" & @CRLF & _
"SL30PB3-4X/V" & @CRLF & _
"SV20PA2-4X/V" & @CRLF & _
"SV10GB3-4X/M/12" & @CRLF & _
"SV30GB3-4X/M" & @CRLF & _
"SV30PB3-4X/V" & @CRLF & _
"SV30GA4-4X/M" & @CRLF & _
"SL10GB1-4X/V" & @CRLF & _
"SV10PB2-4X/V" & @CRLF & _
"SV10PA4-4X/M" & @CRLF & _
"SL10GB1-4X/V/12" & @CRLF & _
"SL10PA2-4X/V" & @CRLF & _
"SV20GA1-4X/M" & @CRLF & _
"SV25GA1-4X/" & @CRLF & _
"SV30GA1-4X/M" & @CRLF & _
"SL20GA1-4X/M" & @CRLF & _
"SL25GA1-4X/" & @CRLF & _
"SL30GA1-4X/M" & @CRLF & _
"SV20PA1-4X/M" & @CRLF & _
"SV30PA1-4X/M" & @CRLF & _
"SL20PA1-4X/M" & @CRLF & _
"SL30PA1-4X/M" & @CRLF & _
"SL10GA3-4X/V" & @CRLF & _
"SV10GA4-4X/M" & @CRLF & _
"SV20PA3-4X/M" & @CRLF & _
"SV20GB1-4X/M" & @CRLF & _
"SL30GA3-4X/V" & @CRLF & _
"SV30PA2-4X/M" & @CRLF & _
"SL30PA2-4X/M" & @CRLF & _
"SV20GB2-4X/M" & @CRLF & _
"SV20PA2-4X/M" & @CRLF & _
"SL20PA2-4X/M" & @CRLF & _
"SL30PA3-4X/M" & @CRLF & _
"SL20PB1-4X/M" & @CRLF & _
"SL20PA3-4X/M" & @CRLF & _
"SV20GA3-4X/M" & @CRLF & _
"SV30PB2-4X/M" & @CRLF & _
"SV30GB1-4X/M" & @CRLF & _
"SL20GA3-4X/M" & @CRLF & _
"SL30GA1-4X/V" & @CRLF & _
"SV30PA3-4X/M" & @CRLF & _
"SL25GB1-4X/" & @CRLF & _
"SL20GA2-4X/M" & @CRLF & _
"SL25GA2-4X/" & @CRLF & _
"SL30PB1-4X/M" & @CRLF & _
"SL20GA2-4X/M/12" & @CRLF & _
"SL30GA4-4X/M/12" & @CRLF & _
"SL10GA4-4X/V" & @CRLF & _
"SL30GA2-4X/M/12" & @CRLF & _
"SL30PA1-4X/MSO286" & @CRLF & _
"SL30GA2-4X/V/12" & @CRLF & _
"SV20PA4-4X/V" & @CRLF & _
"SL30GB1-4X/V" & @CRLF & _
"SL30PA1-4X/MT" & @CRLF & _
"SV20GB1-4X/V/12" & @CRLF & _
"SL20GA4-4X/V" & @CRLF & _
"SL20GA1-4X/6U/M" & @CRLF & _
"SL20GA1-4X/6U/V" & @CRLF & _
"SV10PB3-4X/V" & @CRLF & _
"SV10PA4-4X/V" & @CRLF & _
"SL10PB3-4X/V" & @CRLF & _
"SV30PB1-4X/V" & @CRLF & _
"SV30PA3-4X/V" & @CRLF & _
"SL20PA2-4X/MT" & @CRLF & _
"SV10PA2-4X/M/J3" & @CRLF & _
"SV20PA2-4X/M/J3" & @CRLF & _
"SL30GA4-4X/V" & @CRLF & _
"SV25GB3-4X/V" & @CRLF & _
"SL30GA3-4X/6U/M" & @CRLF & _
"SL20GA3-4X/M/12" & @CRLF & _
"SL10PA1-4X/MT" & @CRLF & _
"SV10PA1-4X=M" & @CRLF & _
"SL30GA1-4X/6U/V" & @CRLF & _
"SL30PB3-4X/6UQMG24M-A08B10P12X99Y00" & @CRLF & _
"SV30GB1-4X/V" & @CRLF & _
"SL20PA1-4X/6U/M-A08B99T00P00X99Y00" & @CRLF & _
"SL20PA2-4X/6U/M-A08B99X99Y00" & @CRLF & _
"SL20PB3-4X/QMG24M" & @CRLF & _
"SL20PB3-4X/QMG24V" & @CRLF & _
"SL20PB3-4X/6UQMG24M-A08B99P00X99Y00" & @CRLF & _
"SL30PB3-4X/6UQMG24M-A08B99P00X99Y00" & @CRLF & _
"SL20GA3-4X/6U/M" & @CRLF & _
"SL30PB3-4X/6UQMG24M-A08B00P12X99Y00" & @CRLF & _
"SL20GA2-4X/6U/M" & @CRLF & _
"SL20GB2-4X/6U/M" & @CRLF & _
"SL20PB3-4X/6UQMG24M-A08B12P00X99Y00" & @CRLF & _
"SL30PA1-4X/6U/M-A08B99X99Y00" & @CRLF & _
"SL30PB3-4X/6UQMG24M-A08B30P00X99Y00" & @CRLF & _
"SL30PB3-4X/6UQMG24M-A08B12P00X99Y00" & @CRLF & _
"SV20GB2-4X/V" & @CRLF & _
"SL30GA1-4X/6U/M" & @CRLF & _
"SL30PA1-4X/6U/M-X00Y00-168" & @CRLF & _
"SV10GB1-4X=M" & @CRLF & _
"SL30PA2-4X/6U/M-X00Y00-168" & @CRLF & _
"SL30PA1-4X=V" & @CRLF & _
"SL30PB3-4X/6UQMG24M-A00B08P12X99Y00" & @CRLF & _
"SL30PA3-4X/6U/M-A08B99X99Y00" & @CRLF & _
"SL20PB1-4X/6U/M-A08B99X99Y00" & @CRLF & _
"SL30PB1-4X/6U/M-A08B99X99Y00" & @CRLF & _
"SL10GA2-4X=M" & @CRLF & _
"SL20PB3-4X/6UQMG24M-A00B00P00X00Y00" & @CRLF & _
"SL20PA2-4X/6U/M-A08B10X99Y00" & @CRLF & _
"SL30GA2-4X/6U/M" & @CRLF & _
"SL20PB3-4X/6UQMG24M-A08B00P12X99Y00" & @CRLF & _
"SL20PB3-4X/6UQMG24M-A00B08P12X99Y00" & @CRLF & _
"SL20PB1-4X/MSO286" & @CRLF & _
"SL20GB3-4X/QMG24M" & @CRLF & _
"SL30PB3-4X/QMG24M" & @CRLF & _
"SL10PB3-4X/QMG24M" & @CRLF & _
"SL10GB3-4X/QMG24M" & @CRLF & _
"SL30GB3-4X/QMG24M" & @CRLF & _
"SV10PB3-4X/QMG24M" & @CRLF & _
"SL25GB3-4X/QMG24" & @CRLF & _
"SV20PB3-4X/QMG24M" & @CRLF & _
"SV10GB3-4X/QMG24M" & @CRLF & _
"SL10PB3-4X/QMG24V" & @CRLF & _
"SV30PB3-4X/QMG24M" & @CRLF & _
"SL30GB3-4X/QMG24V" & @CRLF & _
"SL30PB3-4X/QMG24V" & @CRLF & _
"SL20GB3-4X/QMG24V" & @CRLF & _
"SL10PA3-4X/VJ3" & @CRLF & _
"SL10PA4-4X/VJ3" & @CRLF & _
"SV10GA1-4X/M/J3" & @CRLF & _
"SL30PA1-4X/6U/M-A08B10X99Y00/J3" & @CRLF & _
"SL10PA1-4X/M/J3" & @CRLF & _
"SL10PB3-4X/VJ3" & @CRLF & _
"SV20PA1-4X/M/J3" & @CRLF & _
"SL20PB1-4X/M/J3" & @CRLF & _
"SL20PA1-4X/M/J3" & @CRLF & _
"SL20PA4-4X/M/J3" & @CRLF & _
"SL20PA2-4X/M/J3" & @CRLF & _
"SL30PA3-4X/6U/M-X00Y00-168" & @CRLF & _
"SL20GB3-4X/6UQMG24V" & @CRLF & _
"SL20GB3-4X/6UQMG24M" & @CRLF & _
"SL30GB3-4X/6UQMG24V" & @CRLF & _
"SL30PA1-4X/M/J3" & @CRLF & _
"SL30PA2-4X/M/J3" & @CRLF & _
"SV10PA1-4X/M/J3" & @CRLF & _
"SV10PA3-4X/M/J3" & @CRLF & _
"SV20PB4-4X/V" & @CRLF & _
"SV25GB4-4X/" & @CRLF & _
"SV30GB3-4X/QMG24M" & @CRLF & _
"SV20PA1-4X/VSO286" & @CRLF & _
"SL30GB4-4X/V" & @CRLF & _
"SV30GB3-4X/QMG24/V" & @CRLF & _
"SV10GA1-4X=M" & @CRLF & _
"SV20GB2-4X/V/12" & @CRLF & _
"SV20PA3-4X/M/J3" & @CRLF & _
"SL10PA1-4X/VJ3" & @CRLF & _
"SL30PB3-4X/6UQMG24M-A08B08P12X99Y00" & @CRLF & _
"SL10GA1-4X/M/J3" & @CRLF & _
"SL30GB3-4X/6U/V" & @CRLF & _
"SL20GB3-4X/6U/V" & @CRLF & _
"SL25GB3-4X/QMG24V" & @CRLF & _
"SL10GB3-4X/QMG24V" & @CRLF & _
"SV20GB3-4X/QMG24M" & @CRLF & _
"SV30PB2-4X/MSO286" & @CRLF & _
"SL20PB2-4X/M/J3" & @CRLF & _
"SL30GB3-4X/M/J3" & @CRLF & _
"SV10GB3-4X/QMG24V" & @CRLF & _
"SV20GA1-4X/M/J3" & @CRLF & _
"SL30GB2-4X/M/J3" & @CRLF & _
"SL20PA1-4X=M" & @CRLF & _
"SL20PB4-4X/6U/M-A08B99X99Y00" & @CRLF & _
"SV10PB3-4X/QMG24V" & @CRLF & _
"SL30PB3-4X/6UQMG24M-A08B20P20X99Y00" & @CRLF & _
"SL20PB3-4X/6UQMG24M-A08B20P20X99Y00" & @CRLF & _
"SL20PB3-4X/6UQMG24M-A08B08P00X99Y00" & @CRLF & _
"SL20PB2-4X=M" & @CRLF & _
"SV20PA1-4X=M" & @CRLF & _
"SL20PA1-4X/VJ3" & @CRLF & _
"SL20GA2-4X/V/12" & @CRLF & _
"SL10GA2-4X/V/12" & @CRLF & _
"SV10GB1-4X/V/12" & @CRLF & _
"SL30GB3-4X/M/12" & @CRLF & _
"SL30GB1-4X/M/12" & @CRLF & _
"SV20GB1-4X/V/12" & @CRLF & _
"SL15GB2-4X/12" & @CRLF & _
"SL15GB1-4X/12" & @CRLF & _
"SL15GA1-4X/V/12" & @CRLF & _
"SV20GB2-4X/M/12" & @CRLF & _
"SV30GB2-4X/M/12" & @CRLF & _
"SL15GB4-4X/V/12" & @CRLF & _
"SV30GB2-4X/V/12" & @CRLF & _
"SL30GB3-4X/V/12" & @CRLF & _
"SL20GB3-4X/12" & @CRLF & _
"SL20GA2-4X/12" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")