import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<unit_type>SL|SV)(?P<unit_size>10|15|20|25|30)(?P<mounting_type>P|G)(?P<decompression_feature>A|B)(?P<cracking_pressure>1|2|3|4)(?P<sep_1>-)(?P<unit_series>4X)(?P<sep_2>/|=)(?P<pilot_valve>6U|)(?P<type_of_limit_switch>QM|)(?P<power_supply_of_limit_switch>G24|)(?P<sep_3>/|)(?P<seal_material>M|V|)(?P<sep_4>/|)(?P<surface_coating>J3|)(?P<pipe_port>/12|)(?P<additional_details>(.|[0-9])*)$";
final String string = "SV20PB1-4X/V\n"
+ "SV10GA3-4X/V\n"
+ "SL20GB1-4X/M/12\n"
+ "SV30PB2-4X/V\n"
+ "SV20GA2-4X/V\n"
+ "SL30PB2-4X/V\n"
+ "SV20GB3-4X/M/12\n"
+ "SL20PB4-4X/V\n"
+ "SL10GA1-4X/V/12\n"
+ "SV20GB4-4X/V\n"
+ "SV20GA1-4X=M\n"
+ "SV20GB1-4X/M/12\n"
+ "SL20GA3-4X/V\n"
+ "SV20GA3-4X/M/12\n"
+ "SL30PB4-4X/V\n"
+ "SL20PA1-4X/MSO286\n"
+ "SV10GA2-4X/M/12\n"
+ "SL20GA1-4X/V/12\n"
+ "SL10PB1-4X/MSO286\n"
+ "SV30GB2-4X/V\n"
+ "SV30GA1-4X/V/12\n"
+ "SL30GA1-4X/V/12=\n"
+ "SV30PB4-4X/V\n"
+ "SL25GB3-4X/\n"
+ "SV10GA3-4X/M\n"
+ "SV10GB3-4X/M\n"
+ "SV10PA2-4X/V\n"
+ "SL10PA4-4X/V\n"
+ "SV10PB2-4X/M\n"
+ "SL10PB1-4X/V\n"
+ "SL10PA4-4X/M\n"
+ "SV10PB1-4X/V\n"
+ "SV10GB1-4X/M/12\n"
+ "SL10PB3-4X/M\n"
+ "SV10GB1-4X/V\n"
+ "SL10PA2-4X/M\n"
+ "SL10PA3-4X/M\n"
+ "SL10PB1-4X/M\n"
+ "SL10GA4-4X/M\n"
+ "SL10GB3-4X/M\n"
+ "SL10GA1-4X/M/12\n"
+ "SL10GA1-4X/V\n"
+ "SL10GA2-4X/M\n"
+ "SV10PA2-4X/M\n"
+ "SL10GB1-4X/M\n"
+ "SL10PB4-4X/M\n"
+ "SV10GB1-4X/M\n"
+ "SL10GA3-4X/M\n"
+ "SV10GA2-4X/M\n"
+ "SV10GB4-4X/M\n"
+ "SL10PB2-4X/M\n"
+ "SL10PA1-4X/V\n"
+ "SV10PA3-4X/M\n"
+ "SV10GA1-4X/V/12\n"
+ "SV10PA1-4X/V\n"
+ "SV10PB3-4X/M\n"
+ "SV10GB2-4X/M\n"
+ "SV10GA1-4X/V\n"
+ "SV10PA3-4X/V\n"
+ "SV10PB1-4X/M\n"
+ "SL10GB2-4X/V\n"
+ "SL10GB2-4X/M\n"
+ "SV10GA2-4X/V/12\n"
+ "SV10GA1-4X/M/12\n"
+ "SV10GA2-4X/V\n"
+ "SV10GA1-4X/M\n"
+ "SV10PA1-4X/M\n"
+ "SL10GA1-4X/M\n"
+ "SL10PA1-4X/M\n"
+ "SL30GA3-4X/M\n"
+ "SV30GA3-4X/M\n"
+ "SL20GB2-4X/M\n"
+ "SV20PA1-4X/V\n"
+ "SL30PA1-4X/V\n"
+ "SL20PB2-4X/M\n"
+ "SV20GA2-4X/M\n"
+ "SV20GA1-4X/V\n"
+ "SV10PB4-4X/V\n"
+ "SL20GB1-4X/M\n"
+ "SV25GB3-4X/\n"
+ "SL20PB3-4X/M\n"
+ "SL25GB2-4X/\n"
+ "SL30GB1-4X/M\n"
+ "SL30GA2-4X/M\n"
+ "SL20PA4-4X/M\n"
+ "SV20GB4-4X/M\n"
+ "SL20PA2-4X/V\n"
+ "SV30PA1-4X/V\n"
+ "SV25GA2-4X/\n"
+ "SV30GA2-4X/M\n"
+ "SL20PA3-4X/V\n"
+ "SV20PB3-4X/M\n"
+ "SL20PA1-4X/V\n"
+ "SL30PA4-4X/M\n"
+ "SV20PB1-4X/M\n"
+ "SV20PB2-4X/M\n"
+ "SL30PA4-4X/V\n"
+ "SV30PA2-4X/V\n"
+ "SV20PA3-4X/V\n"
+ "SL30GB2-4X/M\n"
+ "SV30PB1-4X/M\n"
+ "SL30GA1-4X/M/12\n"
+ "SL10GA2-4X/V\n"
+ "SV20GB3-4X/M\n"
+ "SL25GB1-4X/V\n"
+ "SL30GB2-4X/V/12\n"
+ "SL25GA3-4X/\n"
+ "SL30PB2-4X/M\n"
+ "SV30GB2-4X/M\n"
+ "SL20GA1-4X/V\n"
+ "SL20PB2-4X/V\n"
+ "SL10PA3-4X/V\n"
+ "SV30PA4-4X/M\n"
+ "SV10PB4-4X/M\n"
+ "SL30PB3-4X/M\n"
+ "SL25GA1-4X/V\n"
+ "SL20GB3-4X/M\n"
+ "SV25GA2-4X/V\n"
+ "SV20PA1-4X/MSO67\n"
+ "SL10GB1-4X/M/12\n"
+ "SL30PA1-4X/MSO67\n"
+ "SL20GA4-4X/M\n"
+ "SV25GB1-4X/V\n"
+ "SV20PB4-4X/M\n"
+ "SV25GA1-4X/V\n"
+ "SL20GA2-4X/V\n"
+ "SL30PB1-4X/V\n"
+ "SV20GA1-4X/M/12\n"
+ "SL25GA4-4X/\n"
+ "SL20GA1-4X/M/12\n"
+ "SV10GA2-4X/MSO43\n"
+ "SV10GB2-4X/V\n"
+ "SL20PB1-4X/V\n"
+ "SL20GB1-4X/V\n"
+ "SV10GB4-4X/V\n"
+ "SV10GA4-4X/V\n"
+ "SL30GA4-4X/M\n"
+ "SV20GA4-4X/M\n"
+ "SV20GA4-4X/V\n"
+ "SV10GA4-4X/MSO287\n"
+ "SV30PB4-4X/M\n"
+ "SL30PB4-4X/M\n"
+ "SL20PB4-4X/M\n"
+ "SV10GA3-4X/M/12\n"
+ "SL30PA2-4X/V\n"
+ "SV25GA4-4X/\n"
+ "SL10PB2-4X/V\n"
+ "SL20PA4-4X/V\n"
+ "SV30GB4-4X/M\n"
+ "SV30PB3-4X/M\n"
+ "SV25GB1-4X/\n"
+ "SV30GA1-4X/M/12\n"
+ "SV20PB2-4X/V\n"
+ "SL10PA1-4X/MSO286\n"
+ "SV20GA2-4X/M/12\n"
+ "SV20GA1-4X/V/12\n"
+ "SL30PA3-4X/V\n"
+ "SV30GA2-4X/V\n"
+ "SL10GA2-4X/M/12\n"
+ "SL10GB3-4X/V\n"
+ "SV25GB2-4X/\n"
+ "SL20GA1-4X/MSO180\n"
+ "SL30GB3-4X/M\n"
+ "SV25GA3-4X/\n"
+ "SL20GB4-4X/M\n"
+ "SV30PA4-4X/V\n"
+ "SL10PB4-4X/V\n"
+ "SV30GA1-4X/V\n"
+ "SL30GA2-4X/V\n"
+ "SV20GB1-4X/V\n"
+ "SV30GA2-4X/M/12\n"
+ "SL20PA2-4X/MSO67\n"
+ "SV20PA4-4X/M\n"
+ "SL20PB3-4X/V\n"
+ "SL10GB4-4X/M\n"
+ "SL30GB4-4X/M\n"
+ "SL20GB2-4X/V\n"
+ "SL30GB2-4X/V\n"
+ "SL25GB2-4X/V\n"
+ "SL25GA2-4X/V\n"
+ "SL10GB4-4X/V/12\n"
+ "SL20GB3-4X/V\n"
+ "SV30GB1-4X/M/12\n"
+ "SL20GB1-4X/MSO180\n"
+ "SV10PA1-4X/MT\n"
+ "SL30PB3-4X/V\n"
+ "SV20PA2-4X/V\n"
+ "SV10GB3-4X/M/12\n"
+ "SV30GB3-4X/M\n"
+ "SV30PB3-4X/V\n"
+ "SV30GA4-4X/M\n"
+ "SL10GB1-4X/V\n"
+ "SV10PB2-4X/V\n"
+ "SV10PA4-4X/M\n"
+ "SL10GB1-4X/V/12\n"
+ "SL10PA2-4X/V\n"
+ "SV20GA1-4X/M\n"
+ "SV25GA1-4X/\n"
+ "SV30GA1-4X/M\n"
+ "SL20GA1-4X/M\n"
+ "SL25GA1-4X/\n"
+ "SL30GA1-4X/M\n"
+ "SV20PA1-4X/M\n"
+ "SV30PA1-4X/M\n"
+ "SL20PA1-4X/M\n"
+ "SL30PA1-4X/M\n"
+ "SL10GA3-4X/V\n"
+ "SV10GA4-4X/M\n"
+ "SV20PA3-4X/M\n"
+ "SV20GB1-4X/M\n"
+ "SL30GA3-4X/V\n"
+ "SV30PA2-4X/M\n"
+ "SL30PA2-4X/M\n"
+ "SV20GB2-4X/M\n"
+ "SV20PA2-4X/M\n"
+ "SL20PA2-4X/M\n"
+ "SL30PA3-4X/M\n"
+ "SL20PB1-4X/M\n"
+ "SL20PA3-4X/M\n"
+ "SV20GA3-4X/M\n"
+ "SV30PB2-4X/M\n"
+ "SV30GB1-4X/M\n"
+ "SL20GA3-4X/M\n"
+ "SL30GA1-4X/V\n"
+ "SV30PA3-4X/M\n"
+ "SL25GB1-4X/\n"
+ "SL20GA2-4X/M\n"
+ "SL25GA2-4X/\n"
+ "SL30PB1-4X/M\n"
+ "SL20GA2-4X/M/12\n"
+ "SL30GA4-4X/M/12\n"
+ "SL10GA4-4X/V\n"
+ "SL30GA2-4X/M/12\n"
+ "SL30PA1-4X/MSO286\n"
+ "SL30GA2-4X/V/12\n"
+ "SV20PA4-4X/V\n"
+ "SL30GB1-4X/V\n"
+ "SL30PA1-4X/MT\n"
+ "SV20GB1-4X/V/12\n"
+ "SL20GA4-4X/V\n"
+ "SL20GA1-4X/6U/M\n"
+ "SL20GA1-4X/6U/V\n"
+ "SV10PB3-4X/V\n"
+ "SV10PA4-4X/V\n"
+ "SL10PB3-4X/V\n"
+ "SV30PB1-4X/V\n"
+ "SV30PA3-4X/V\n"
+ "SL20PA2-4X/MT\n"
+ "SV10PA2-4X/M/J3\n"
+ "SV20PA2-4X/M/J3\n"
+ "SL30GA4-4X/V\n"
+ "SV25GB3-4X/V\n"
+ "SL30GA3-4X/6U/M\n"
+ "SL20GA3-4X/M/12\n"
+ "SL10PA1-4X/MT\n"
+ "SV10PA1-4X=M\n"
+ "SL30GA1-4X/6U/V\n"
+ "SL30PB3-4X/6UQMG24M-A08B10P12X99Y00\n"
+ "SV30GB1-4X/V\n"
+ "SL20PA1-4X/6U/M-A08B99T00P00X99Y00\n"
+ "SL20PA2-4X/6U/M-A08B99X99Y00\n"
+ "SL20PB3-4X/QMG24M\n"
+ "SL20PB3-4X/QMG24V\n"
+ "SL20PB3-4X/6UQMG24M-A08B99P00X99Y00\n"
+ "SL30PB3-4X/6UQMG24M-A08B99P00X99Y00\n"
+ "SL20GA3-4X/6U/M\n"
+ "SL30PB3-4X/6UQMG24M-A08B00P12X99Y00\n"
+ "SL20GA2-4X/6U/M\n"
+ "SL20GB2-4X/6U/M\n"
+ "SL20PB3-4X/6UQMG24M-A08B12P00X99Y00\n"
+ "SL30PA1-4X/6U/M-A08B99X99Y00\n"
+ "SL30PB3-4X/6UQMG24M-A08B30P00X99Y00\n"
+ "SL30PB3-4X/6UQMG24M-A08B12P00X99Y00\n"
+ "SV20GB2-4X/V\n"
+ "SL30GA1-4X/6U/M\n"
+ "SL30PA1-4X/6U/M-X00Y00-168\n"
+ "SV10GB1-4X=M\n"
+ "SL30PA2-4X/6U/M-X00Y00-168\n"
+ "SL30PA1-4X=V\n"
+ "SL30PB3-4X/6UQMG24M-A00B08P12X99Y00\n"
+ "SL30PA3-4X/6U/M-A08B99X99Y00\n"
+ "SL20PB1-4X/6U/M-A08B99X99Y00\n"
+ "SL30PB1-4X/6U/M-A08B99X99Y00\n"
+ "SL10GA2-4X=M\n"
+ "SL20PB3-4X/6UQMG24M-A00B00P00X00Y00\n"
+ "SL20PA2-4X/6U/M-A08B10X99Y00\n"
+ "SL30GA2-4X/6U/M\n"
+ "SL20PB3-4X/6UQMG24M-A08B00P12X99Y00\n"
+ "SL20PB3-4X/6UQMG24M-A00B08P12X99Y00\n"
+ "SL20PB1-4X/MSO286\n"
+ "SL20GB3-4X/QMG24M\n"
+ "SL30PB3-4X/QMG24M\n"
+ "SL10PB3-4X/QMG24M\n"
+ "SL10GB3-4X/QMG24M\n"
+ "SL30GB3-4X/QMG24M\n"
+ "SV10PB3-4X/QMG24M\n"
+ "SL25GB3-4X/QMG24\n"
+ "SV20PB3-4X/QMG24M\n"
+ "SV10GB3-4X/QMG24M\n"
+ "SL10PB3-4X/QMG24V\n"
+ "SV30PB3-4X/QMG24M\n"
+ "SL30GB3-4X/QMG24V\n"
+ "SL30PB3-4X/QMG24V\n"
+ "SL20GB3-4X/QMG24V\n"
+ "SL10PA3-4X/VJ3\n"
+ "SL10PA4-4X/VJ3\n"
+ "SV10GA1-4X/M/J3\n"
+ "SL30PA1-4X/6U/M-A08B10X99Y00/J3\n"
+ "SL10PA1-4X/M/J3\n"
+ "SL10PB3-4X/VJ3\n"
+ "SV20PA1-4X/M/J3\n"
+ "SL20PB1-4X/M/J3\n"
+ "SL20PA1-4X/M/J3\n"
+ "SL20PA4-4X/M/J3\n"
+ "SL20PA2-4X/M/J3\n"
+ "SL30PA3-4X/6U/M-X00Y00-168\n"
+ "SL20GB3-4X/6UQMG24V\n"
+ "SL20GB3-4X/6UQMG24M\n"
+ "SL30GB3-4X/6UQMG24V\n"
+ "SL30PA1-4X/M/J3\n"
+ "SL30PA2-4X/M/J3\n"
+ "SV10PA1-4X/M/J3\n"
+ "SV10PA3-4X/M/J3\n"
+ "SV20PB4-4X/V\n"
+ "SV25GB4-4X/\n"
+ "SV30GB3-4X/QMG24M\n"
+ "SV20PA1-4X/VSO286\n"
+ "SL30GB4-4X/V\n"
+ "SV30GB3-4X/QMG24/V\n"
+ "SV10GA1-4X=M\n"
+ "SV20GB2-4X/V/12\n"
+ "SV20PA3-4X/M/J3\n"
+ "SL10PA1-4X/VJ3\n"
+ "SL30PB3-4X/6UQMG24M-A08B08P12X99Y00\n"
+ "SL10GA1-4X/M/J3\n"
+ "SL30GB3-4X/6U/V\n"
+ "SL20GB3-4X/6U/V\n"
+ "SL25GB3-4X/QMG24V\n"
+ "SL10GB3-4X/QMG24V\n"
+ "SV20GB3-4X/QMG24M\n"
+ "SV30PB2-4X/MSO286\n"
+ "SL20PB2-4X/M/J3\n"
+ "SL30GB3-4X/M/J3\n"
+ "SV10GB3-4X/QMG24V\n"
+ "SV20GA1-4X/M/J3\n"
+ "SL30GB2-4X/M/J3\n"
+ "SL20PA1-4X=M\n"
+ "SL20PB4-4X/6U/M-A08B99X99Y00\n"
+ "SV10PB3-4X/QMG24V\n"
+ "SL30PB3-4X/6UQMG24M-A08B20P20X99Y00\n"
+ "SL20PB3-4X/6UQMG24M-A08B20P20X99Y00\n"
+ "SL20PB3-4X/6UQMG24M-A08B08P00X99Y00\n"
+ "SL20PB2-4X=M\n"
+ "SV20PA1-4X=M\n"
+ "SL20PA1-4X/VJ3\n"
+ "SL20GA2-4X/V/12\n"
+ "SL10GA2-4X/V/12\n"
+ "SV10GB1-4X/V/12\n"
+ "SL30GB3-4X/M/12\n"
+ "SL30GB1-4X/M/12\n"
+ "SV20GB1-4X/V/12\n"
+ "SL15GB2-4X/12\n"
+ "SL15GB1-4X/12\n"
+ "SL15GA1-4X/V/12\n"
+ "SV20GB2-4X/M/12\n"
+ "SV30GB2-4X/M/12\n"
+ "SL15GB4-4X/V/12\n"
+ "SV30GB2-4X/V/12\n"
+ "SL30GB3-4X/V/12\n"
+ "SL20GB3-4X/12\n"
+ "SL20GA2-4X/12\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}