package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\S+(?:ая|ые|ый|ья))(?:\s|$)`)
var str = `большие большая простые тест тестовым тестовые беличья
больш ие проыесторые`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}