$re = '/(\S+(?:ая|ые|ый|ья))(?:\s|$)/i';
$str = 'большие большая простые тест тестовым тестовые беличья
большие проыесторые';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);