package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m):\s*(.*?)(?:\s*#line:.*)?$`)
var str = `Sally: Hello there #line:34de2f
Bob: How are you today?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}