// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m):\s*(.*?)(?:\s*#line:.*)?$").unwrap();
let string = "Sally: Hello there #line:34de2f
Bob: How are you today?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}