$re = '/^#{1,4}\s(?!.*\[#.*\]$).*/m';
$str = '## My Big Heading [#my-big-anchor]
## My Big Heading';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);