re = /^#{1,4}\s(?!.*\[#.*\]$).*/m
str = '## My Big Heading [#my-big-anchor]
## My Big Heading'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end