#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:0\.\d*[1-9]\d*|[1-9]\d*(?:\.\d+)?)$"
Local $sString = "12" & @CRLF & _
"1.3234" & @CRLF & _
"0.3423434" & @CRLF & _
"23423.12" & @CRLF & _
"" & @CRLF & _
"0" & @CRLF & _
"0.000" & @CRLF & _
"00.0" & @CRLF & _
"00" & @CRLF & _
"0012" & @CRLF & _
"12.324.12" & @CRLF & _
"01.2332" & @CRLF & _
".12" & @CRLF & _
"121212."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")