$re = '/^(?:0\.\d*[1-9]\d*|[1-9]\d*(?:\.\d+)?)$/m';
$str = '12
1.3234
0.3423434
23423.12
0
0.000
00.0
00
0012
12.324.12
01.2332
.12
121212.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);