# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([0-9]{4}-[0-9]{2}-[0-9]{2,}|[\d]{0,}|[NnaAOoEe]{0,})(.*)"
test_str = ("2020-10-2125Chavez and Sons\n"
"2020-05-02Bean Inc\n"
"NaNRobinson, Mcmahon and Atkins\n"
"2020-04-25Hill-Fisher\n"
"2020-04-02Nothing and Sons\n"
"52457Carpenter and Sons\n"
"0Carpenter and Sons\n"
"Carpenter and Sons\n"
"NoneEconomy and Sons\n"
"2020-04-02\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.