import re
regex = re.compile(r"((?:[01]\d|2[0-3]):(?:[0-5]\d):(?:[0-5]\d)) \| (Player) \"(.+)\" (.+) \(id=(.+) (.+)=<(.+)>(.+)\"(.+)\" \(id=(.+)\<(.+)\>(.+)with (.+) from (.+) meters", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("18:43:44 | Player \"Holomo33\" (DEAD) (id=2vL1MZXKHD4qwgO6NSjoThiISfINy5SmNmuhAkbwYHM= pos=<4715.3, 10763.7, 346.8>) killed by Player \"X-CYPHER-3\" (id=aVfM8ohBvcljkZtt5CB77JOY7SNoBAh-sYK0ejvNPJc= pos=<4789.6, 10828.5, 335.4>) with LAR from 99.2274 meters \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")