import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Total_Cases[^a-zA-Z]*).*";
final String string = "/nOpenCases - 4 - - - 4 /nClosed_Cases 6 - - - - 6 /nTotal_Cases 3 4 - - - 7 Rocket Star Services Limited Term Disability FLK1234567 As Of 12/21/2023 property of xyz. Use and distribution limited solely to personnel. © Copyright 2020 Rocket Corporation) 9 of 15 Created: 3:20 PM - 1/21/2020";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}