$re = '/^[0-9]?+(,\d{3})*\.[0-9]{2}$/m';
$str = '.12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);