package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[(0-9),-]+(\b|\n)`)
var str = `123-(455)
Office365@gmail.com
12a1 1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}