$re = '/\b[(0-9),-]+(\b|\n)/';
$str = '123-(455)
Office365@gmail.com
12a1 1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);