package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Pass=([0-9]+).*classification_error_evaluator=(0\.[0-9]+).*classification_error_evaluator=(0\.[0-9]+)`)
var str = `I0419 01:52:16.606123 136 TrainerInternal.cpp:181] Pass=15 Batch=74 samples=3670 AvgCost=263.331 Eval: classification_error_evaluator=0.970178 I0419 01:52:16.815407 136 Tester.cpp:115] Test samples=458 cost=203.737 Eval: classification_error_evaluator=0.934446`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}