import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(text\\] (?:\\[option1/option2\\])(?: \\[text)?|(?:\\[option1/option2\\]) \\[text)";
final String string = "text [option1/option2] text\n"
+ "text] [option1/option2] more text\n"
+ "text [option1/option2] [text\n"
+ "text] [option1/option2] [text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}