// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(text\] (?:\[option1/option2\])(?: \[text)?|(?:\[option1/option2\]) \[text)").unwrap();
let string = "text [option1/option2] text
text] [option1/option2] more text
text [option1/option2] [text
text] [option1/option2] [text";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}