#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^www\.example\.(?:com|co(?:\.(?:in|uk))?|net|us|me)\/([^\/\n]+)\/([^\/\n]+)$"
Local $sString = "www.example.com" & @CRLF & _
"www.example.com/" & @CRLF & _
"www.example.com/example1" & @CRLF & _
"www.example.net/example1/" & @CRLF & _
"www.example.co.uk/example1/something" & @CRLF & _
"www.example.co.in/example1/something/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")