import Foundation
let pattern = #"^www\.example\.(?:com|co(?:\.(?:in|uk))?|net|us|me)\/([^\/\n]+)\/([^\/\n]+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
www.example.com
www.example.com/
www.example.com/example1
www.example.net/example1/
www.example.co.uk/example1/something
www.example.co.in/example1/something/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)