const regex = /^(([A-Za-z0-9-_+]+(?:\.[A-Za-z0-9-_]+)*)@([A-Za-z0-9-]+(?:\.[A-Za-z0-9]+)*(?:\.[A-Za-z]{2,})))$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([A-Za-z0-9-_+]+(?:\\.[A-Za-z0-9-_]+)*)@([A-Za-z0-9-]+(?:\\.[A-Za-z0-9]+)*(?:\\.[A-Za-z]{2,})))$', '')
const str = `email_the-best+1@gmail.com.es.edu`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}