re = /^(([A-Za-z0-9-_+]+(?:\.[A-Za-z0-9-_]+)*)@([A-Za-z0-9-]+(?:\.[A-Za-z0-9]+)*(?:\.[A-Za-z]{2,})))$/
str = 'email_the-best+1@gmail.com.es.edu'
# Print the match result
str.match(re) do |match|
puts match.to_s
end