import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\]\\s*(AN|AV)\\s+1\\s+([\\w\\s]+)\\s+2\\s+([\\w\\s]+)\\s+3\\s+((?=.*\\bda cui\\b)|(?!=.*\\bda cui\\b).*)";
final String string = "] AN 1 campo 2 prato con penna B sps a 1 3 campo con penna C as a 1 cfr Nota filologica \n"
+ "] AN 1 campo 2 prato con penna B sps a 1 3 da cui campo con penna C as a 1 cfr Nota filologica \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}