re = /\]\s*(AN|AV)\s+1\s+([\w\s]+)\s+2\s+([\w\s]+)\s+3\s+((?=.*\bda cui\b)|(?!=.*\bda cui\b).*)/m
str = '] AN 1 campo 2 prato con penna B sps a 1 3 campo con penna C as a 1 cfr Nota filologica
] AN 1 campo 2 prato con penna B sps a 1 3 da cui campo con penna C as a 1 cfr Nota filologica
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end