using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\]\s*(AN|AV)\s+1\s+([\w\s]+)\s+2\s+([\w\s]+)\s+3\s+((?=.*\bda cui\b)|(?!=.*\bda cui\b).*)";
string input = @"] AN 1 campo 2 prato con penna B sps a 1 3 campo con penna C as a 1 cfr Nota filologica
] AN 1 campo 2 prato con penna B sps a 1 3 da cui campo con penna C as a 1 cfr Nota filologica
] AN 1 campo 2 prato con penna B sps a 1 3 da cuio campo con penna C as a 1 cfr Nota filologica
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}