#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?<!\bsub )\btotal\b\D*(\d+(?:\.\d+))"
Local $sString = "Friscos #8603" & @CRLF & _
"8100 E. Orchard Road" & @CRLF & _
"Greenwood Village, Colorado 80111" & @CRLF & _
"2013-11-02" & @CRLF & _
"Table 00" & @CRLF & _
"Guest" & @CRLF & _
"1 Oysters 1/2 Shell #1" & @CRLF & _
"1 Crab Cake" & @CRLF & _
"1 Filet 1602 Bone In" & @CRLF & _
"1 Ribeye 22oz Bone In" & @CRLF & _
"1 Asparagus" & @CRLF & _
"1 Potato Au Gratin" & @CRLF & _
"$17.00" & @CRLF & _
"$19.00" & @CRLF & _
"$66.00" & @CRLF & _
"$53.00" & @CRLF & _
"$12.00" & @CRLF & _
"$11.50" & @CRLF & _
"Sub Total" & @CRLF & _
"Tax" & @CRLF & _
"$178.50" & @CRLF & _
"$12.94" & @CRLF & _
"Total" & @CRLF & _
"$191.44" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Berghotel" & @CRLF & _
"Grosse Scheidegg" & @CRLF & _
"3818 Grindelwald" & @CRLF & _
"Familie R. Müller" & @CRLF & _
"Rech. Nr. 4572" & @CRLF & _
"Bar" & @CRLF & _
"30.07.2007/13:29:17" & @CRLF & _
"Tisch 7/01" & @CRLF & _
"NM" & @CRLF & _
"#ರ" & @CRLF & _
"2xLatte Macchiato à 4.50 CHF" & @CRLF & _
"1xGloki" & @CRLF & _
"à 5.00 CHF" & @CRLF & _
"1xSchweinschnitzel à 22.00 CHF" & @CRLF & _
"1xChässpätzli à 18.50 CHF" & @CRLF & _
"#ರ #ರ #1ರ" & @CRLF & _
"5.00" & @CRLF & _
"22.00" & @CRLF & _
"18.50" & @CRLF & _
"Total:" & @CRLF & _
"CHF" & @CRLF & _
"54.50" & @CRLF & _
"Incl. 7.6% MwSt" & @CRLF & _
"54.50 CHF:" & @CRLF & _
"3.85" & @CRLF & _
"Entspricht in Euro 36.33 EUR" & @CRLF & _
"Es bediente Sie: Ursula" & @CRLF & _
"MwSt Nr. : 430 234" & @CRLF & _
"Tel.: 033 853 67 16" & @CRLF & _
"Fax.: 033 853 67 19" & @CRLF & _
"E-mail: grossescheidegg@bluewin.ch" & @CRLF & _
"'" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")