# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\bsub )\btotal\b\D*(\d+(?:\.\d+))"
test_str = ("Friscos #8603\n"
"8100 E. Orchard Road\n"
"Greenwood Village, Colorado 80111\n"
"2013-11-02\n"
"Table 00\n"
"Guest\n"
"1 Oysters 1/2 Shell #1\n"
"1 Crab Cake\n"
"1 Filet 1602 Bone In\n"
"1 Ribeye 22oz Bone In\n"
"1 Asparagus\n"
"1 Potato Au Gratin\n"
"$17.00\n"
"$19.00\n"
"$66.00\n"
"$53.00\n"
"$12.00\n"
"$11.50\n"
"Sub Total\n"
"Tax\n"
"$178.50\n"
"$12.94\n"
"Total\n"
"$191.44\n\n\n"
"Berghotel\n"
"Grosse Scheidegg\n"
"3818 Grindelwald\n"
"Familie R. Müller\n"
"Rech. Nr. 4572\n"
"Bar\n"
"30.07.2007/13:29:17\n"
"Tisch 7/01\n"
"NM\n"
"#ರ\n"
"2xLatte Macchiato à 4.50 CHF\n"
"1xGloki\n"
"à 5.00 CHF\n"
"1xSchweinschnitzel à 22.00 CHF\n"
"1xChässpätzli à 18.50 CHF\n"
"#ರ #ರ #1ರ\n"
"5.00\n"
"22.00\n"
"18.50\n"
"Total:\n"
"CHF\n"
"54.50\n"
"Incl. 7.6% MwSt\n"
"54.50 CHF:\n"
"3.85\n"
"Entspricht in Euro 36.33 EUR\n"
"Es bediente Sie: Ursula\n"
"MwSt Nr. : 430 234\n"
"Tel.: 033 853 67 16\n"
"Fax.: 033 853 67 19\n"
"E-mail: grossescheidegg@bluewin.ch\n"
"'\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.