$re = '/(?<=[([])[^()[\]]*(?=[)\]])/m';
$str = 'Example_(xxxxx)_AND_(yyyyy)_2019-01-28';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);