re = /(?<=[([])[^()[\]]*(?=[)\]])/m
str = 'Example_(xxxxx)_AND_(yyyyy)_2019-01-28'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end