#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\r\n]*(?<=\\)("|\\)[^\r\n]*$"
Local $sString = "abc d" & @CRLF & _
"my \"laser\"" & @CRLF & _
"D:\\willi\\badehose" & @CRLF & _
"foo\\\"bar" & @CRLF & _
"" & @CRLF & _
"my "laser"" & @CRLF & _
"D:\willi\badehose" & @CRLF & _
"foo\\"bar" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")