const regex = /^[^\r\n]*(?<=\\)("|\\)[^\r\n]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\r\\n]*(?<=\\\\)("|\\\\)[^\\r\\n]*$', 'gm')
const str = `abc d
my \\"laser\\"
D:\\\\willi\\\\badehose
foo\\\\\\"bar
my "laser"
D:\\willi\\badehose
foo\\\\"bar
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}