#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:<R((?:.*?\r?\n?)*)E>)"
Local $sString = "set cli-parameters base 10 api brief enabled pager disabled" & @CRLF & _
"<?xml version="1.0" encoding="UTF-8" standalone="yes"?>" & @CRLF & _
"<RESPONSE VERSION="L100">" & @CRLF & _
"<COMP G="0" P="1"/> <OBJECT basetype="status" name="status" oid="1">" & @CRLF & _
" <PROPERTY name="response-type" type="string">Success</PROPERTY>" & @CRLF & _
" <PROPERTY name="response-type-numeric" type="string">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="response" type="string">Command completed successfully. - The settings were changed successfully. (2018-02-27 17:29:42)</PROPERTY>" & @CRLF & _
" <PROPERTY name="return-code" type="sint32">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="component-id" type="string"></PROPERTY>" & @CRLF & _
" <PROPERTY name="time-stamp" type="string">2018-02-27 17:29:42</PROPERTY>" & @CRLF & _
" <PROPERTY name="time-stamp-numeric" type="string">1519752582</PROPERTY>" & @CRLF & _
" </OBJECT>" & @CRLF & _
"</RESPONSE>" & @CRLF & _
"# show disks 1.1" & @CRLF & _
"<?xml version="1.0" encoding="UTF-8" standalone="yes"?>" & @CRLF & _
"<RESPONSE VERSION="L100">" & @CRLF & _
"<COMP G="0" P="1"/> <OBJECT basetype="drives" name="drive" oid="1" format="rows">" & @CRLF & _
" <PROPERTY name="durable-id" type="string">disk_1.1</PROPERTY>" & @CRLF & _
" <PROPERTY name="enclosure-id" type="uint32">1</PROPERTY>" & @CRLF & _
" <PROPERTY name="slot" type="uint32">1</PROPERTY>" & @CRLF & _
" <PROPERTY name="location" key="true" type="string">1.1</PROPERTY>" & @CRLF & _
" <PROPERTY name="port" type="uint32">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="scsi-id" type="uint32">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="blocks" blocksize="512" type="uint64">1172123568</PROPERTY>" & @CRLF & _
" <PROPERTY name="serial-number" type="string">CZWWV6DN</PROPERTY>" & @CRLF & _
" <PROPERTY name="vendor" type="string">HITACHI</PROPERTY>" & @CRLF & _
" <PROPERTY name="model" type="string">HUS156060VLS600</PROPERTY>" & @CRLF & _
" <PROPERTY name="revision" type="string">A5D0</PROPERTY>" & @CRLF & _
" <PROPERTY name="state" type="string">FAILED</PROPERTY>" & @CRLF & _
" <PROPERTY name="secondary-channel" type="uint32">1</PROPERTY>" & @CRLF & _
" <PROPERTY name="container-index" type="uint32">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="member-index" type="uint32">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="type" type="string">SAS</PROPERTY>" & @CRLF & _
" <PROPERTY name="type-numeric" type="string">4</PROPERTY>" & @CRLF & _
" <PROPERTY name="pi-format" type="string">UNKN</PROPERTY>" & @CRLF & _
" <PROPERTY name="pi-format-numeric" type="string">3</PROPERTY>" & @CRLF & _
" <PROPERTY name="job-running" type="string"></PROPERTY>" & @CRLF & _
" <PROPERTY name="job-running-numeric" type="string">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="blink" type="uint32">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="speed" type="uint32">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="lun" type="uint32">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="smart" type="string">Enabled</PROPERTY>" & @CRLF & _
" <PROPERTY name="smart-numeric" type="string">1</PROPERTY>" & @CRLF & _
" <PROPERTY name="dual-port" type="uint32">1</PROPERTY>" & @CRLF & _
" <PROPERTY name="error" type="uint32">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="fc-p1-channel" type="uint32">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="fc-p1-device-id" type="uint32">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="fc-p1-node-wwn" type="string">5000cca0416aff98</PROPERTY>" & @CRLF & _
" <PROPERTY name="fc-p1-port-wwn" type="string">0000000000000000</PROPERTY>" & @CRLF & _
" <PROPERTY name="fc-p1-unit-number" type="uint32">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="fc-p2-channel" type="uint32">1</PROPERTY>" & @CRLF & _
" <PROPERTY name="fc-p2-device-id" type="uint32">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="fc-p2-node-wwn" type="string"></PROPERTY>" & @CRLF & _
" <PROPERTY name="fc-p2-port-wwn" type="string"></PROPERTY>" & @CRLF & _
" <PROPERTY name="fc-p2-unit-number" type="uint32">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="drive-down-code" type="uint8">1</PROPERTY>" & @CRLF & _
" <PROPERTY name="owner" type="string">A</PROPERTY>" & @CRLF & _
" <PROPERTY name="owner-numeric" type="string">1</PROPERTY>" & @CRLF & _
" <PROPERTY name="index" type="uint32">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="rpm" units="K" type="uint32">15</PROPERTY>" & @CRLF & _
" <PROPERTY name="size" units="GB" type="string">600.1GB</PROPERTY>" & @CRLF & _
" <PROPERTY name="size-numeric" units="blocks512" type="string">1172123568</PROPERTY>" & @CRLF & _
" <PROPERTY name="transfer-rate" units="gbps" type="string">6.0</PROPERTY>" & @CRLF & _
" <PROPERTY name="transfer-rate-numeric" units="gbps" type="string">19</PROPERTY>" & @CRLF & _
" <PROPERTY name="attributes" type="string"></PROPERTY>" & @CRLF & _
" <PROPERTY name="attributes-numeric" type="string">19</PROPERTY>" & @CRLF & _
" <PROPERTY name="virtual-disk-serial" type="string"></PROPERTY>" & @CRLF & _
" <PROPERTY name="enclosure-wwn" type="string">500c0ff01957bd3c</PROPERTY>" & @CRLF & _
" <PROPERTY name="status" type="string">Up</PROPERTY>" & @CRLF & _
" <PROPERTY name="usage" type="string">FAILED</PROPERTY>" & @CRLF & _
" <PROPERTY name="operation" type="string">IDLE</PROPERTY>" & @CRLF & _
" <PROPERTY name="led-status" type="string"> Fault</PROPERTY>" & @CRLF & _
" <PROPERTY name="led-status-numeric" type="string">4</PROPERTY>" & @CRLF & _
" <PROPERTY name="disk-dsd-count" type="uint32">1</PROPERTY>" & @CRLF & _
" <PROPERTY name="number-of-ios" type="uint64">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="total-data-transferred" units="B" type="string">0B</PROPERTY>" & @CRLF & _
" <PROPERTY name="total-data-transferred-numeric" type="string">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="avg-rsp-time" type="uint64">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="health" type="string">Fault</PROPERTY>" & @CRLF & _
" <PROPERTY name="health-numeric" type="string">2</PROPERTY>" & @CRLF & _
" <PROPERTY name="health-reason" type="string">Excessive media errors.</PROPERTY>" & @CRLF & _
" <PROPERTY name="health-recommendation" type="string">- Replace the disk.</PROPERTY>" & @CRLF & _
" </OBJECT>" & @CRLF & _
"<COMP G="0" P="2"/> <OBJECT basetype="status" name="status" oid="2">" & @CRLF & _
" <PROPERTY name="response-type" type="string">Info</PROPERTY>" & @CRLF & _
" <PROPERTY name="response-type-numeric" type="string">2</PROPERTY>" & @CRLF & _
" <PROPERTY name="response" type="string">* Rates may vary. This is normal behavior. (2018-02-27 17:29:42)</PROPERTY>" & @CRLF & _
" <PROPERTY name="return-code" type="sint32">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="component-id" type="string"></PROPERTY>" & @CRLF & _
" <PROPERTY name="time-stamp" type="string">2018-02-27 17:29:42</PROPERTY>" & @CRLF & _
" <PROPERTY name="time-stamp-numeric" type="string">1519752582</PROPERTY>" & @CRLF & _
" </OBJECT>" & @CRLF & _
"<COMP G="0" P="3"/> <OBJECT basetype="status" name="status" oid="3">" & @CRLF & _
" <PROPERTY name="response-type" type="string">Success</PROPERTY>" & @CRLF & _
" <PROPERTY name="response-type-numeric" type="string">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="response" type="string">Command completed successfully. (2018-02-27 17:29:42)</PROPERTY>" & @CRLF & _
" <PROPERTY name="return-code" type="sint32">0</PROPERTY>" & @CRLF & _
" <PROPERTY name="component-id" type="string"></PROPERTY>" & @CRLF & _
" <PROPERTY name="time-stamp" type="string">2018-02-27 17:29:42</PROPERTY>" & @CRLF & _
" <PROPERTY name="time-stamp-numeric" type="string">1519752582</PROPERTY>" & @CRLF & _
" </OBJECT>" & @CRLF & _
"</RESPONSE>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")