import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<R((?:.*?\\r?\\n?)*)E>)";
final String string = "set cli-parameters base 10 api brief enabled pager disabled\n"
+ "<?xml version=\"1.0\" encoding=\"UTF-8\" standalone=\"yes\"?>\n"
+ "<RESPONSE VERSION=\"L100\">\n"
+ "<COMP G=\"0\" P=\"1\"/> <OBJECT basetype=\"status\" name=\"status\" oid=\"1\">\n"
+ " <PROPERTY name=\"response-type\" type=\"string\">Success</PROPERTY>\n"
+ " <PROPERTY name=\"response-type-numeric\" type=\"string\">0</PROPERTY>\n"
+ " <PROPERTY name=\"response\" type=\"string\">Command completed successfully. - The settings were changed successfully. (2018-02-27 17:29:42)</PROPERTY>\n"
+ " <PROPERTY name=\"return-code\" type=\"sint32\">0</PROPERTY>\n"
+ " <PROPERTY name=\"component-id\" type=\"string\"></PROPERTY>\n"
+ " <PROPERTY name=\"time-stamp\" type=\"string\">2018-02-27 17:29:42</PROPERTY>\n"
+ " <PROPERTY name=\"time-stamp-numeric\" type=\"string\">1519752582</PROPERTY>\n"
+ " </OBJECT>\n"
+ "</RESPONSE>\n"
+ "# show disks 1.1\n"
+ "<?xml version=\"1.0\" encoding=\"UTF-8\" standalone=\"yes\"?>\n"
+ "<RESPONSE VERSION=\"L100\">\n"
+ "<COMP G=\"0\" P=\"1\"/> <OBJECT basetype=\"drives\" name=\"drive\" oid=\"1\" format=\"rows\">\n"
+ " <PROPERTY name=\"durable-id\" type=\"string\">disk_1.1</PROPERTY>\n"
+ " <PROPERTY name=\"enclosure-id\" type=\"uint32\">1</PROPERTY>\n"
+ " <PROPERTY name=\"slot\" type=\"uint32\">1</PROPERTY>\n"
+ " <PROPERTY name=\"location\" key=\"true\" type=\"string\">1.1</PROPERTY>\n"
+ " <PROPERTY name=\"port\" type=\"uint32\">0</PROPERTY>\n"
+ " <PROPERTY name=\"scsi-id\" type=\"uint32\">0</PROPERTY>\n"
+ " <PROPERTY name=\"blocks\" blocksize=\"512\" type=\"uint64\">1172123568</PROPERTY>\n"
+ " <PROPERTY name=\"serial-number\" type=\"string\">CZWWV6DN</PROPERTY>\n"
+ " <PROPERTY name=\"vendor\" type=\"string\">HITACHI</PROPERTY>\n"
+ " <PROPERTY name=\"model\" type=\"string\">HUS156060VLS600</PROPERTY>\n"
+ " <PROPERTY name=\"revision\" type=\"string\">A5D0</PROPERTY>\n"
+ " <PROPERTY name=\"state\" type=\"string\">FAILED</PROPERTY>\n"
+ " <PROPERTY name=\"secondary-channel\" type=\"uint32\">1</PROPERTY>\n"
+ " <PROPERTY name=\"container-index\" type=\"uint32\">0</PROPERTY>\n"
+ " <PROPERTY name=\"member-index\" type=\"uint32\">0</PROPERTY>\n"
+ " <PROPERTY name=\"type\" type=\"string\">SAS</PROPERTY>\n"
+ " <PROPERTY name=\"type-numeric\" type=\"string\">4</PROPERTY>\n"
+ " <PROPERTY name=\"pi-format\" type=\"string\">UNKN</PROPERTY>\n"
+ " <PROPERTY name=\"pi-format-numeric\" type=\"string\">3</PROPERTY>\n"
+ " <PROPERTY name=\"job-running\" type=\"string\"></PROPERTY>\n"
+ " <PROPERTY name=\"job-running-numeric\" type=\"string\">0</PROPERTY>\n"
+ " <PROPERTY name=\"blink\" type=\"uint32\">0</PROPERTY>\n"
+ " <PROPERTY name=\"speed\" type=\"uint32\">0</PROPERTY>\n"
+ " <PROPERTY name=\"lun\" type=\"uint32\">0</PROPERTY>\n"
+ " <PROPERTY name=\"smart\" type=\"string\">Enabled</PROPERTY>\n"
+ " <PROPERTY name=\"smart-numeric\" type=\"string\">1</PROPERTY>\n"
+ " <PROPERTY name=\"dual-port\" type=\"uint32\">1</PROPERTY>\n"
+ " <PROPERTY name=\"error\" type=\"uint32\">0</PROPERTY>\n"
+ " <PROPERTY name=\"fc-p1-channel\" type=\"uint32\">0</PROPERTY>\n"
+ " <PROPERTY name=\"fc-p1-device-id\" type=\"uint32\">0</PROPERTY>\n"
+ " <PROPERTY name=\"fc-p1-node-wwn\" type=\"string\">5000cca0416aff98</PROPERTY>\n"
+ " <PROPERTY name=\"fc-p1-port-wwn\" type=\"string\">0000000000000000</PROPERTY>\n"
+ " <PROPERTY name=\"fc-p1-unit-number\" type=\"uint32\">0</PROPERTY>\n"
+ " <PROPERTY name=\"fc-p2-channel\" type=\"uint32\">1</PROPERTY>\n"
+ " <PROPERTY name=\"fc-p2-device-id\" type=\"uint32\">0</PROPERTY>\n"
+ " <PROPERTY name=\"fc-p2-node-wwn\" type=\"string\"></PROPERTY>\n"
+ " <PROPERTY name=\"fc-p2-port-wwn\" type=\"string\"></PROPERTY>\n"
+ " <PROPERTY name=\"fc-p2-unit-number\" type=\"uint32\">0</PROPERTY>\n"
+ " <PROPERTY name=\"drive-down-code\" type=\"uint8\">1</PROPERTY>\n"
+ " <PROPERTY name=\"owner\" type=\"string\">A</PROPERTY>\n"
+ " <PROPERTY name=\"owner-numeric\" type=\"string\">1</PROPERTY>\n"
+ " <PROPERTY name=\"index\" type=\"uint32\">0</PROPERTY>\n"
+ " <PROPERTY name=\"rpm\" units=\"K\" type=\"uint32\">15</PROPERTY>\n"
+ " <PROPERTY name=\"size\" units=\"GB\" type=\"string\">600.1GB</PROPERTY>\n"
+ " <PROPERTY name=\"size-numeric\" units=\"blocks512\" type=\"string\">1172123568</PROPERTY>\n"
+ " <PROPERTY name=\"transfer-rate\" units=\"gbps\" type=\"string\">6.0</PROPERTY>\n"
+ " <PROPERTY name=\"transfer-rate-numeric\" units=\"gbps\" type=\"string\">19</PROPERTY>\n"
+ " <PROPERTY name=\"attributes\" type=\"string\"></PROPERTY>\n"
+ " <PROPERTY name=\"attributes-numeric\" type=\"string\">19</PROPERTY>\n"
+ " <PROPERTY name=\"virtual-disk-serial\" type=\"string\"></PROPERTY>\n"
+ " <PROPERTY name=\"enclosure-wwn\" type=\"string\">500c0ff01957bd3c</PROPERTY>\n"
+ " <PROPERTY name=\"status\" type=\"string\">Up</PROPERTY>\n"
+ " <PROPERTY name=\"usage\" type=\"string\">FAILED</PROPERTY>\n"
+ " <PROPERTY name=\"operation\" type=\"string\">IDLE</PROPERTY>\n"
+ " <PROPERTY name=\"led-status\" type=\"string\"> Fault</PROPERTY>\n"
+ " <PROPERTY name=\"led-status-numeric\" type=\"string\">4</PROPERTY>\n"
+ " <PROPERTY name=\"disk-dsd-count\" type=\"uint32\">1</PROPERTY>\n"
+ " <PROPERTY name=\"number-of-ios\" type=\"uint64\">0</PROPERTY>\n"
+ " <PROPERTY name=\"total-data-transferred\" units=\"B\" type=\"string\">0B</PROPERTY>\n"
+ " <PROPERTY name=\"total-data-transferred-numeric\" type=\"string\">0</PROPERTY>\n"
+ " <PROPERTY name=\"avg-rsp-time\" type=\"uint64\">0</PROPERTY>\n"
+ " <PROPERTY name=\"health\" type=\"string\">Fault</PROPERTY>\n"
+ " <PROPERTY name=\"health-numeric\" type=\"string\">2</PROPERTY>\n"
+ " <PROPERTY name=\"health-reason\" type=\"string\">Excessive media errors.</PROPERTY>\n"
+ " <PROPERTY name=\"health-recommendation\" type=\"string\">- Replace the disk.</PROPERTY>\n"
+ " </OBJECT>\n"
+ "<COMP G=\"0\" P=\"2\"/> <OBJECT basetype=\"status\" name=\"status\" oid=\"2\">\n"
+ " <PROPERTY name=\"response-type\" type=\"string\">Info</PROPERTY>\n"
+ " <PROPERTY name=\"response-type-numeric\" type=\"string\">2</PROPERTY>\n"
+ " <PROPERTY name=\"response\" type=\"string\">* Rates may vary. This is normal behavior. (2018-02-27 17:29:42)</PROPERTY>\n"
+ " <PROPERTY name=\"return-code\" type=\"sint32\">0</PROPERTY>\n"
+ " <PROPERTY name=\"component-id\" type=\"string\"></PROPERTY>\n"
+ " <PROPERTY name=\"time-stamp\" type=\"string\">2018-02-27 17:29:42</PROPERTY>\n"
+ " <PROPERTY name=\"time-stamp-numeric\" type=\"string\">1519752582</PROPERTY>\n"
+ " </OBJECT>\n"
+ "<COMP G=\"0\" P=\"3\"/> <OBJECT basetype=\"status\" name=\"status\" oid=\"3\">\n"
+ " <PROPERTY name=\"response-type\" type=\"string\">Success</PROPERTY>\n"
+ " <PROPERTY name=\"response-type-numeric\" type=\"string\">0</PROPERTY>\n"
+ " <PROPERTY name=\"response\" type=\"string\">Command completed successfully. (2018-02-27 17:29:42)</PROPERTY>\n"
+ " <PROPERTY name=\"return-code\" type=\"sint32\">0</PROPERTY>\n"
+ " <PROPERTY name=\"component-id\" type=\"string\"></PROPERTY>\n"
+ " <PROPERTY name=\"time-stamp\" type=\"string\">2018-02-27 17:29:42</PROPERTY>\n"
+ " <PROPERTY name=\"time-stamp-numeric\" type=\"string\">1519752582</PROPERTY>\n"
+ " </OBJECT>\n"
+ "</RESPONSE>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}