package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`filename_[^\.]*\.jpg`)
var str = `filename_*.*.jpg
filename_*.jpg
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}