$re = '/filename_[^\.]*\.jpg/';
$str = 'filename_*.*.jpg
filename_*.jpg
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);