package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^=?(?<KEY>[^=]+)=(?<VALUE>.*)$`)
var str = `=location=
=location=some place`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}