$re = '/^=?(?<KEY>[^=]+)=(?<VALUE>.*)$/m';
$str = '=location=
=location=some place';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);