#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)intervals \[\d+\]:\s+\Kxmin = (?P<xmin>\d+(\.\d+)?) \" & @CRLF & _
" \s+xmax = (?P<xmax>\d+(\.\d+)?)\s+text = "(?P<text>[^"]*)""
Local $sString = "intervals [1]:" & @CRLF & _
" xmin = 0 " & @CRLF & _
" xmax = 13.139997023062838 " & @CRLF & _
" text = "" " & @CRLF & _
" intervals [2]:" & @CRLF & _
" xmin = 13.139997023062838 " & @CRLF & _
" xmax = 14.763036269953904 " & @CRLF & _
" text = "Cities are like siblings in a large polygamous family." " & @CRLF & _
" intervals [3]:" & @CRLF & _
" xmin = 14.763036269953904 " & @CRLF & _
" xmax = 17.01 " & @CRLF & _
" text = "" " & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")