import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "const \\{(?s)(.*)\\}.*?(?=const)";
final String string = "const {\n"
+ " b {\n"
+ " description \"Create B1\"\n"
+ " uri \"ms:///a/v1/create-b\"\n"
+ " }\n"
+ " c {\n"
+ " description \"Create C1\"\n"
+ " uri \"ms:///a/v1/create-c\"\n"
+ " }\n"
+ " d {\n"
+ " description \"Create D1\"\n"
+ " uri \"ms:///a/v1/create-d\"\n"
+ " }\n"
+ "}\n\n"
+ "const {\n"
+ " b {\n"
+ " description \"Create B2\"\n"
+ " uri \"ms:///a/v1/create-b\"\n"
+ " }\n"
+ " c {\n"
+ " description \"Create C2\"\n"
+ " uri \"ms:///a/v1/create-c\"\n"
+ " }\n"
+ " d {\n"
+ " description \"Create D2\"\n"
+ " uri \"ms:///a/v1/create-d\"\n"
+ " }\n"
+ "}\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}